{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-44082 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-44082 is a medium-severity vulnerability in n/a, published on 6 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-44082 and fix it if it is affected.\n\nWhat it is: CVE-2024-44082 is a medium-severity vulnerability in n/a, published on 6 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-44082 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-44082/ (Markdown: https://insights.sbomify.com/CVE-2024-44082/index.md)","id":"CVE-2024-44082","markdown":"https://insights.sbomify.com/CVE-2024-44082/index.md","name":"CVE-2024-44082","record":{"aliases":["DEBIAN-CVE-2024-44082","RHSA-2024:9982","RHSA-2025:0204","UBUNTU-CVE-2024-44082","USN-6989-1"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenStack Ironic","requires_auth":"low_privilege","summary":"An authenticated user can exploit crafted images to access sensitive data via qemu-img in OpenStack Ironic.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: \u003c21.4.3, \u003e=22.0.0 \u003c23.0.2, \u003e=23.1.0 \u003c24.1.2, \u003e=25.0.0 \u003c26.0.1; Ironic-python-agent: \u003c9.4.2, \u003e=9.5.0 \u003c9.7.1, \u003e=9.8.0 \u003c9.11.1, \u003e=9.12.0 \u003c9.13.1.","ecosystems":["Red Hat:openstack:16.2::el8","Red Hat:openstack:17.1::el9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2024-44082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":8,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2024-44083"},"packages":[{"ecosystem":"Red Hat:openstack:16.2::el8","fixed":["1:13.0.8-2.20230713045150.d10fd5c.el8ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic","purl":"pkg:rpm/redhat/openstack-ironic","source":"RHSA-2025:0204"},{"ecosystem":"Red Hat:openstack:16.2::el8","fixed":["1:13.0.8-2.20230713045150.d10fd5c.el8ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-api","purl":"pkg:rpm/redhat/openstack-ironic-api","source":"RHSA-2025:0204"},{"ecosystem":"Red Hat:openstack:16.2::el8","fixed":["1:13.0.8-2.20230713045150.d10fd5c.el8ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-common","purl":"pkg:rpm/redhat/openstack-ironic-common","source":"RHSA-2025:0204"},{"ecosystem":"Red Hat:openstack:16.2::el8","fixed":["1:13.0.8-2.20230713045150.d10fd5c.el8ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-conductor","purl":"pkg:rpm/redhat/openstack-ironic-conductor","source":"RHSA-2025:0204"},{"ecosystem":"Red Hat:openstack:17.1::el9","fixed":["1:17.1.1-17.1.20240917210749.c31db88.el9ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic","purl":"pkg:rpm/redhat/openstack-ironic","source":"RHSA-2024:9982"},{"ecosystem":"Red Hat:openstack:17.1::el9","fixed":["1:17.1.1-17.1.20240917210749.c31db88.el9ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-api","purl":"pkg:rpm/redhat/openstack-ironic-api","source":"RHSA-2024:9982"},{"ecosystem":"Red Hat:openstack:17.1::el9","fixed":["1:17.1.1-17.1.20240917210749.c31db88.el9ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-common","purl":"pkg:rpm/redhat/openstack-ironic-common","source":"RHSA-2024:9982"},{"ecosystem":"Red Hat:openstack:17.1::el9","fixed":["1:17.1.1-17.1.20240917210749.c31db88.el9ost"],"introduced":["0"],"last_affected":[],"package":"openstack-ironic-conductor","purl":"pkg:rpm/redhat/openstack-ironic-conductor","source":"RHSA-2024:9982"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-44081"},"products":["n/a"],"published":"2024-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-06","vendors":["n/a"]},"summary":"An authenticated user can exploit crafted images to access sensitive data via qemu-img in OpenStack Ironic.","url":"https://insights.sbomify.com/CVE-2024-44082/"}