CVE-2024-44088 Apache Geode: Reflected XSS

Medium 6.1 Published Updated

Reflected XSS in Apache Geode REST API allows attackers to steal session information or take over accounts via crafted links.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-44088?

CVE-2024-44088 is a medium-severity cross-site scripting vulnerability in Apache Geode, published on 14 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover.

This issue affects Apache Geode: all versions prior to 1.15.2

Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-44088?

2 open source packages ship an affected version, including org.apache.geode:geode-web-api. It affects 1 product.

PackageAffectedFixed in
org.apache.geode:geode-web-api MavenFrom 1.1.01.15.2
org.apache.geode:geode-web-api MavenFrom 1.1.01.15.2

Products include Apache Geode.

How do I fix CVE-2024-44088?

Upgrade org.apache.geode:geode-web-api to 1.15.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-44088 being exploited?

There is no known exploitation of CVE-2024-44088 in the wild and no public exploit code.

Sources

Also known as GHSA-w595-4975-gm3h.

Is CVE-2024-44088 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free