{"answers":{"affected":"2 open source packages ship an affected version, including tastyigniter/tastyigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-44314 in the wild and no public exploit code.","fix":"Upgrade tastyigniter/tastyigniter to 4.0.0 or later.","what":"CVE-2024-44314 is a medium-severity missing authorization vulnerability in n/a, published on 18 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-44314 and fix it if it is affected.\n\nWhat it is: CVE-2024-44314 is a medium-severity missing authorization vulnerability in n/a, published on 18 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-44314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 4.0.0\n- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-44314/ (Markdown: https://insights.sbomify.com/CVE-2024-44314/index.md)","id":"CVE-2024-44314","markdown":"https://insights.sbomify.com/CVE-2024-44314/index.md","name":"CVE-2024-44314","record":{"aliases":["GHSA-w5h7-mw56-4v7x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"TastyIgniter e-commerce","requires_auth":"low_privilege","summary":"Unauthorized users can remotely update order statuses in TastyIgniter due to missing permission checks in the Orders Management System.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tastyigniter","vendor":"tastyigniter"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TastyIgniter Has an Incorrect Access Control Vulnerability","id":"CVE-2024-44314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2024-44331"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"tastyigniter/tastyigniter","purl":null,"source":"GHSA-w5h7-mw56-4v7x"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"tastyigniter/tastyigniter","purl":"pkg:composer/tastyigniter/tastyigniter","source":"GHSA-w5h7-mw56-4v7x"}],"prev":{"headline":"TastyIgniter Has an Incorrect Access Control Vulnerability via `invoice()` Function","id":"CVE-2024-44313"},"products":["n/a"],"published":"2025-03-18","related":[{"cvss_score":8.8,"headline":"TastyIgniter vulnerable to Cross-Site Scripting","id":"CVE-2025-61417","kev_date_added":null,"published":"2025-10-20"},{"cvss_score":8.1,"headline":"TastyIgniter Has an Incorrect Access Control Vulnerability via `invoice()` Function","id":"CVE-2024-44313","kev_date_added":null,"published":"2025-03-18"},{"cvss_score":7.4,"headline":"Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter","id":"CVE-2022-0602","kev_date_added":null,"published":"2022-04-05"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2022-38256","kev_date_added":null,"published":"2022-09-08"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2022-23378","kev_date_added":null,"published":"2022-02-09"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2021-38699","kev_date_added":null,"published":"2021-08-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["n/a"]},"summary":"Unauthorized users can remotely update order statuses in TastyIgniter due to missing permission checks in the Orders Management System.","url":"https://insights.sbomify.com/CVE-2024-44314/"}