# CVE-2024-44314: TastyIgniter Has an Incorrect Access Control Vulnerability

> Unauthorized users can remotely update order statuses in TastyIgniter due to missing permission checks in the Orders Management System.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** GHSA-w5h7-mw56-4v7x

## What is CVE-2024-44314?

CVE-2024-44314 is a medium-severity missing authorization vulnerability in n/a, published on 18 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-44314?

2 open source packages ship an affected version, including tastyigniter/tastyigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tastyigniter/tastyigniter` | Packagist | All versions | 4.0.0 |
| `tastyigniter/tastyigniter` | Packagist | All versions | 4.0.0 |

Products: Tastyigniter Tastyigniter.

## How do I fix CVE-2024-44314?

Upgrade tastyigniter/tastyigniter to 4.0.0 or later.

## Is CVE-2024-44314 being exploited?

There is no known exploitation of CVE-2024-44314 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-61417](https://insights.sbomify.com/CVE-2025-61417/): TastyIgniter vulnerable to Cross-Site Scripting (high 8.8)
- [CVE-2024-44313](https://insights.sbomify.com/CVE-2024-44313/): TastyIgniter Has an Incorrect Access Control Vulnerability via `invoice()` Function (high 8.1)
- [CVE-2022-0602](https://insights.sbomify.com/CVE-2022-0602/): Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter (high 7.4)
- [CVE-2022-38256](https://insights.sbomify.com/CVE-2022-38256/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2022-23378](https://insights.sbomify.com/CVE-2022-23378/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-44314 and fix it if it is affected.

What it is: CVE-2024-44314 is a medium-severity missing authorization vulnerability in n/a, published on 18 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-44314 in the wild and no public exploit code.

Affected packages and fixed versions:
- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 4.0.0
- tastyigniter/tastyigniter (Packagist): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-44314/ (Markdown: https://insights.sbomify.com/CVE-2024-44314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-44314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-44314
- OSV: https://osv.dev/vulnerability/CVE-2024-44314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-44314/
Summaries are generated and may contain mistakes; the official description above is the record.
