CVE-2024-4439 Cross-site scripting in WordPress

High 7.2 Published Updated

Authenticated or unauthenticated attackers can inject arbitrary scripts via display names in the Avatar block, leading to script execution on victim pages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4439?

CVE-2024-4439 is a high-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 3 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. In addition, it also makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that have the comment block present and display the comment author's avatar.

Weakness: CWE-80

Which versions are affected by CVE-2024-4439?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.

PackageAffectedFixed in
wordpress BitnamiFrom 6.0.06.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2
wordpress-multisite BitnamiFrom 6.0.06.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2

Products include Wordpress Wordpress.

How do I fix CVE-2024-4439?

Upgrade wordpress to a fixed version for your release line: 6.0.8, 6.1.6, 6.2.5 or 6.3.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-4439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4439 exists.

Public exploit code: 1 Nuclei template and 5 proofs of concept on GitHub.

All Wordpress Wordpress vulnerabilities

Sources

Also known as BIT-wordpress-2024-4439, BIT-wordpress-multisite-2024-4439, DEBIAN-CVE-2024-4439, GHSA-682x-vcqv-v7v6, UBUNTU-CVE-2024-4439.

Is CVE-2024-4439 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free