{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4439 exists.","fix":"Upgrade wordpress to a fixed version for your release line: 6.0.8, 6.1.6, 6.2.5 or 6.3.4.","what":"CVE-2024-4439 is a high-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 3 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-4439 and fix it if it is affected.\n\nWhat it is: CVE-2024-4439 is a high-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 3 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4439 exists.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 6.0.0; fixed in 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2\n- wordpress-multisite (Bitnami): affected from 6.0.0; fixed in 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-4439/ (Markdown: https://insights.sbomify.com/CVE-2024-4439/index.md)","id":"CVE-2024-4439","markdown":"https://insights.sbomify.com/CVE-2024-4439/index.md","name":"CVE-2024-4439","record":{"aliases":["BIT-wordpress-2024-4439","BIT-wordpress-multisite-2024-4439","DEBIAN-CVE-2024-4439","GHSA-682x-vcqv-v7v6","UBUNTU-CVE-2024-4439"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress Core","requires_auth":"none","summary":"Authenticated or unauthenticated attackers can inject arbitrary scripts via display names in the Avatar block, leading to script execution on victim pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. In addition, it also makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that have the comment block present and display the comment author's avatar.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-05-06","github_poc":5,"max_poc_stars":12,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-05-06T09:07:36Z","kind":"github_poc","ref":"https://github.com/d0rb/CVE-2024-4439","stars":12,"title":"The provided exploit code leverages a stored Cross-Site Scripting (XSS) vulnerability (CVE-2024-4439) in WordPress Core versions up to 6.5.1."},{"date":"2024-05-06T08:50:23Z","kind":"github_poc","ref":"https://github.com/MielPopsssssss/CVE-2024-4439","stars":2,"title":"CVE-2024-4439 PoC"},{"date":"2024-05-20T23:39:54Z","kind":"github_poc","ref":"https://github.com/xssor-dz/-CVE-2024-4439","stars":0,"title":"WordPress Core \u003c 6.5.2 - Unauthenticated \u0026 Authenticated (Contributor+) Stored Cross-Site Scripting via Avatar Block"},{"date":"2024-10-10T09:30:11Z","kind":"github_poc","ref":"https://github.com/soltanali0/CVE-2024-4439","stars":0,"title":"aa"},{"date":"2024-11-21T13:36:25Z","kind":"github_poc","ref":"https://github.com/w0r1i0g1ht/CVE-2024-4439","stars":0,"title":"CVE-2024-4439 docker and poc"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-4439.yaml","stars":null,"title":"WordPress Core \u003c6.5.2 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in WordPress","id":"CVE-2024-4439","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"xss","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in Xpro Addons — 140+ Widgets for Elementor","id":"CVE-2024-4440"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.8","6.1.6","6.2.5","6.3.4","6.4.4","6.5.2"],"introduced":["6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-4439"},{"ecosystem":"Bitnami","fixed":["6.0.8","6.1.6","6.2.5","6.3.4","6.4.4","6.5.2"],"introduced":["6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-4439"}],"prev":{"headline":"Etcd: incomplete fix for cve-2023-39325/cve-2023-44487 in openstack platform","id":"CVE-2024-4438"},"products":["WordPress"],"published":"2024-05-03","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["WordPress Foundation"]},"summary":"Authenticated or unauthenticated attackers can inject arbitrary scripts via display names in the Avatar block, leading to script execution on victim pages.","url":"https://insights.sbomify.com/CVE-2024-4439/"}