# CVE-2024-4439: Cross-site scripting in WordPress

> Authenticated or unauthenticated attackers can inject arbitrary scripts via display names in the Avatar block, leading to script execution on victim pages.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-wordpress-2024-4439, BIT-wordpress-multisite-2024-4439, DEBIAN-CVE-2024-4439, GHSA-682x-vcqv-v7v6, UBUNTU-CVE-2024-4439

## What is CVE-2024-4439?

CVE-2024-4439 is a high-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 3 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. In addition, it also makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that have the comment block present and display the comment author's avatar.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-4439?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 6.0.0 | 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2 |
| `wordpress-multisite` | Bitnami | From 6.0.0 | 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2024-4439?

Upgrade wordpress to a fixed version for your release line: 6.0.8, 6.1.6, 6.2.5 or 6.3.4.

## Is CVE-2024-4439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4439 exists.

Public exploit code:

- The provided exploit code leverages a stored Cross-Site Scripting (XSS) vulnerability (CVE-2024-4439) in WordPress Core versions up to 6.5.1. (github_poc): https://github.com/d0rb/CVE-2024-4439
- CVE-2024-4439 PoC (github_poc): https://github.com/MielPopsssssss/CVE-2024-4439
- WordPress Core < 6.5.2 - Unauthenticated & Authenticated (Contributor+) Stored Cross-Site Scripting via Avatar Block (github_poc): https://github.com/xssor-dz/-CVE-2024-4439
- aa (github_poc): https://github.com/soltanali0/CVE-2024-4439
- CVE-2024-4439 docker and poc (github_poc): https://github.com/w0r1i0g1ht/CVE-2024-4439
- WordPress Core <6.5.2 - Cross-Site Scripting (nuclei): http/cves/2024/CVE-2024-4439.yaml

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-4439 and fix it if it is affected.

What it is: CVE-2024-4439 is a high-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 3 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-4439 exists.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 6.0.0; fixed in 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2
- wordpress-multisite (Bitnami): affected from 6.0.0; fixed in 6.0.8, 6.1.6, 6.2.5, 6.3.4, 6.4.4, 6.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-4439/ (Markdown: https://insights.sbomify.com/CVE-2024-4439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-4439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-4439
- OSV: https://osv.dev/vulnerability/CVE-2024-4439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-4439/
Summaries are generated and may contain mistakes; the official description above is the record.
