CVE-2024-4442 Salon booking system <= 9.9 - Unauthenticated Arbitrary File Deletion
Unauthenticated attackers can delete arbitrary files, including configuration files, potentially leading to site takeover and remote code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-4442?
CVE-2024-4442 is a critical path traversal vulnerability in wordpresschef Salon Booking System – Free Version, published on 21 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0. CVE-2024-37231 appears to be a duplicate of this issue.
Weakness: CWE-22
Which versions are affected by CVE-2024-4442?
It affects 1 product.
Products include Salonbookingsystem Salon Booking System.
How do I fix CVE-2024-4442?
No fix has been published for CVE-2024-4442 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-4442 being exploited?
There is no known exploitation of CVE-2024-4442 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in wordpresschef Salon Booking System – Free Version
- CVE-2024-30510 WordPress Salon booking system plugin <= 9.5 - Arbitrary File Upload vulnerability
- CVE-2024-3229 Salon Booking System <= 10.2 - Unauthenticated Arbitrary File Upload
- CVE-2024-37231 WordPress Salon booking system plugin <= 9.9 - Arbitrary File Deletion vulnerability
- CVE-2024-39658 WordPress Salon Booking System plugin <= 10.7 - Authenticated SQL Injection vulnerability
- CVE-2022-0920 Salon booking system < 7.6.3 - Customer+ Bookings/Customers Data Disclosure
Sources
Also known as GHSA-rrv6-pjjr-4r3x.