CVE-2024-4472 Insertion of Sensitive Information into Log File in GitLab
Attackers with log access can view dependency proxy credentials leaked in GraphQL logs, requiring an upgrade to GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-4472?
CVE-2024-4472 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.5 prior to 17.1.7, starting from 17.2 prior to 17.2.5, and starting from 17.3 prior to 17.3.2, where dependency proxy credentials are retained in graphql Logs.
Weakness: CWE-532
Which versions are affected by CVE-2024-4472?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.5.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-4472?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Is CVE-2024-4472 being exploited?
There is no known exploitation of CVE-2024-4472 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-4472, GHSA-g8hg-rjf5-vfrm, UBUNTU-CVE-2024-4472.