{"answers":{"affected":"2 open source packages ship an affected version, including topthink/framework. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-44902 exists.","fix":"No fix has been published for CVE-2024-44902 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-44902 is a critical unsafe deserialization vulnerability in n/a, published on 9 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-44902 and fix it if it is affected.\n\nWhat it is: CVE-2024-44902 is a critical unsafe deserialization vulnerability in n/a, published on 9 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-44902 exists.\n\nAffected packages and fixed versions:\n- topthink/framework (Packagist): affected from 6.1.3 up to 8.0.4; no fix listed\n- topthink/framework (Packagist): affected from 6.1.3 up to 8.0.4; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-44902/ (Markdown: https://insights.sbomify.com/CVE-2024-44902/index.md)","id":"CVE-2024-44902","markdown":"https://insights.sbomify.com/CVE-2024-44902/index.md","name":"CVE-2024-44902","record":{"aliases":["GHSA-f4wh-359g-4pq7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary code via a deserialization flaw in the ThinkPHP framework, requiring immediate upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"thinkphp","vendor":"thinkphp"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A deserialization vulnerability in Thinkphp v6.1.3 to v8.0.4 allows attackers to execute arbitrary code.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2024-09-05","github_poc":2,"max_poc_stars":6,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-09-05T15:22:22Z","kind":"github_poc","ref":"https://github.com/fru1ts/CVE-2024-44902","stars":6,"title":null},{"date":"2025-12-10T03:06:18Z","kind":"github_poc","ref":"https://github.com/KrE80r/CVE-2024-44902-env","stars":0,"title":"Vulnerable ThinkPHP 8.0.4 test environment for CVE-2024-44902 nuclei template validation"}],"tier":"weaponised"},"has_fix":false,"headline":"ThinkPHP deserialization vulnerability","id":"CVE-2024-44902","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in IPAC20","id":"CVE-2024-44903"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["6.1.3"],"last_affected":["8.0.4"],"package":"topthink/framework","purl":null,"source":"GHSA-f4wh-359g-4pq7"},{"ecosystem":"Packagist","fixed":[],"introduced":["6.1.3"],"last_affected":["8.0.4"],"package":"topthink/framework","purl":"pkg:composer/topthink/framework","source":"GHSA-f4wh-359g-4pq7"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2024-44893"},"products":["n/a"],"published":"2024-09-09","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2025-63888","kev_date_added":null,"published":"2025-11-20"},{"cvss_score":9.8,"headline":"ThinkPHP Path Traversal Vulnerability","id":"CVE-2025-50706","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2025-50707","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":9.8,"headline":"ThinkPHP deserialization vulnerability","id":"CVE-2024-48112","kev_date_added":null,"published":"2024-10-30"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in thinkphp","id":"CVE-2022-45982","kev_date_added":null,"published":"2023-02-08"},{"cvss_score":9.8,"headline":"ThinkPHP Framework vulnerable to remote code execution","id":"CVE-2022-47945","kev_date_added":null,"published":"2022-12-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via a deserialization flaw in the ThinkPHP framework, requiring immediate upgrades.","url":"https://insights.sbomify.com/CVE-2024-44902/"}