{"answers":{"affected":"3 open source packages ship an affected version, including github.com/uptrace/bun/driver/pgdriver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-44906 in the wild and no public exploit code.","fix":"Upgrade github.com/uptrace/bun/driver/pgdriver to 1.2.15 or later.","what":"CVE-2024-44906 is a medium-severity SQL injection vulnerability in n/a, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-44906 and fix it if it is affected.\n\nWhat it is: CVE-2024-44906 is a medium-severity SQL injection vulnerability in n/a, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-44906 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/uptrace/bun/driver/pgdriver (Go): affected all versions; fixed in 1.2.15\n- github.com/uptrace/bun/driver/pgdriver (Go): affected all versions; fixed in 1.2.15\n- github.com/uptrace/bun/driver/pgdriver (Go): affected all versions; fixed in 1.2.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-44906/ (Markdown: https://insights.sbomify.com/CVE-2024-44906/index.md)","id":"CVE-2024-44906","markdown":"https://insights.sbomify.com/CVE-2024-44906/index.md","name":"CVE-2024-44906","record":{"aliases":["GHSA-h4h6-vccr-44h2","GO-2025-3765"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Go PostgreSQL driver","requires_auth":"none","summary":"A SQL injection vulnerability in the uptrace pgdriver Go library allows attackers to manipulate database queries via the appendArg function.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pgdriver","vendor":"uptrace"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"uptrace pgdriver v1.2.1 was discovered to contain a SQL injection vulnerability via the appendArg function in /pgdriver/format.go. The maintainer has stated that the issue is fixed in v1.2.15.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"uptrace pgdriver SQL injection vulnerability","id":"CVE-2024-44906","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-44910"},"packages":[{"ecosystem":"Go","fixed":["1.2.15"],"introduced":["0"],"last_affected":[],"package":"github.com/uptrace/bun/driver/pgdriver","purl":null,"source":"GHSA-h4h6-vccr-44h2"},{"ecosystem":"Go","fixed":["1.2.15"],"introduced":["0"],"last_affected":[],"package":"github.com/uptrace/bun/driver/pgdriver","purl":"pkg:golang/github.com/uptrace/bun/driver/pgdriver","source":"GHSA-h4h6-vccr-44h2"},{"ecosystem":"Go","fixed":["1.2.15"],"introduced":["0"],"last_affected":[],"package":"github.com/uptrace/bun/driver/pgdriver","purl":"pkg:golang/github.com/uptrace/bun/driver/pgdriver","source":"GO-2025-3765"}],"prev":{"headline":"go-pg SQL injection vulnerability via the component /types/append_value.go","id":"CVE-2024-44905"},"products":["n/a"],"published":"2025-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-13","vendors":["n/a"]},"summary":"A SQL injection vulnerability in the uptrace pgdriver Go library allows attackers to manipulate database queries via the appendArg function.","url":"https://insights.sbomify.com/CVE-2024-44906/"}