CVE-2024-45033 Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli
Attackers can maintain active sessions after a password change via CLI, bypassing session invalidation mechanisms in Apache Airflow.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45033?
CVE-2024-45033 is a high-severity vulnerability in Apache Airflow Fab Provider, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.
This issue affects Apache Airflow Fab Provider: before 1.5.2.
When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9 which was addressed in Apache-Airflow 2.7.0
Users are recommended to upgrade to version 1.5.2, which fixes the issue.
Weakness: CWE-613
Which versions are affected by CVE-2024-45033?
3 open source packages ship an affected version, including apache-airflow-providers-fab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow-providers-fab PyPI | All versions | 1.5.2 |
apache-airflow-providers-fab PyPI | All versions | 1.5.2 |
apache-airflow-providers-fab PyPI | All versions | 1.5.2 |
Products include Apache Apache-Airflow-Providers-Fab.
How do I fix CVE-2024-45033?
Upgrade apache-airflow-providers-fab to 1.5.2 or later.
Is CVE-2024-45033 being exploited?
There is no known exploitation of CVE-2024-45033 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow Fab Provider
- CVE-2026-82311 Security feature bypass in Apache Airflow FAB provider
- CVE-2026-59243 Auth bypass in Apache Airflow FAB provider
- CVE-2024-42447 Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow
- CVE-2026-86462 Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions
- CVE-2026-75156 Auth bypass in Apache Airflow FAB provider
Sources
Also known as GHSA-8863-4qmg-fr45, PYSEC-2026-1147.