{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-fab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45033 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-fab to 1.5.2 or later.","what":"CVE-2024-45033 is a high-severity vulnerability in Apache Airflow Fab Provider, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45033 and fix it if it is affected.\n\nWhat it is: CVE-2024-45033 is a high-severity vulnerability in Apache Airflow Fab Provider, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45033 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2\n- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2\n- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45033/ (Markdown: https://insights.sbomify.com/CVE-2024-45033/index.md)","id":"CVE-2024-45033","markdown":"https://insights.sbomify.com/CVE-2024-45033/index.md","name":"CVE-2024-45033","record":{"aliases":["GHSA-8863-4qmg-fr45","PYSEC-2026-1147"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow plugin","requires_auth":"low_privilege","summary":"Attackers can maintain active sessions after a password change via CLI, bypassing session invalidation mechanisms in Apache Airflow.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-fab","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.\n\nThis issue affects Apache Airflow Fab Provider: before 1.5.2.\n\nWhen user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0\n\nUsers are recommended to upgrade to version 1.5.2, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli","id":"CVE-2024-45033","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Apache Airflow: Authenticated DAG authors could execute code on scheduler nodes","id":"CVE-2024-45034"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":null,"source":"GHSA-8863-4qmg-fr45"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","source":"GHSA-8863-4qmg-fr45"},{"ecosystem":"PyPI","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","source":"PYSEC-2026-1147"}],"prev":{"headline":"Auth bypass in Industrial Edge Management Pro","id":"CVE-2024-45032"},"products":["Apache Airflow Fab Provider"],"published":"2025-01-08","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Apache Airflow FAB provider","id":"CVE-2026-82311","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":9.8,"headline":"Auth bypass in Apache Airflow FAB provider","id":"CVE-2026-59243","kev_date_added":null,"published":"2026-07-29"},{"cvss_score":9.8,"headline":"Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow","id":"CVE-2024-42447","kev_date_added":null,"published":"2024-08-05"},{"cvss_score":9.1,"headline":"Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions","id":"CVE-2026-86462","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":9.1,"headline":"Auth bypass in Apache Airflow FAB provider","id":"CVE-2026-75156","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":8.1,"headline":"Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated","id":"CVE-2026-86466","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":8.1,"headline":"Privilege escalation in Apache Airflow FAB provider","id":"CVE-2026-59245","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-08","vendors":["Apache Software Foundation"]},"summary":"Attackers can maintain active sessions after a password change via CLI, bypassing session invalidation mechanisms in Apache Airflow.","url":"https://insights.sbomify.com/CVE-2024-45033/"}