# CVE-2024-45033: Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli

> Attackers can maintain active sessions after a password change via CLI, bypassing session invalidation mechanisms in Apache Airflow.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2025
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-8863-4qmg-fr45, PYSEC-2026-1147

## What is CVE-2024-45033?

CVE-2024-45033 is a high-severity vulnerability in Apache Airflow Fab Provider, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.

This issue affects Apache Airflow Fab Provider: before 1.5.2.

When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0

Users are recommended to upgrade to version 1.5.2, which fixes the issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2024-45033?

3 open source packages ship an affected version, including apache-airflow-providers-fab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-fab` | PyPI | All versions | 1.5.2 |
| `apache-airflow-providers-fab` | PyPI | All versions | 1.5.2 |
| `apache-airflow-providers-fab` | PyPI | All versions | 1.5.2 |

Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2024-45033?

Upgrade apache-airflow-providers-fab to 1.5.2 or later.

## Is CVE-2024-45033 being exploited?

There is no known exploitation of CVE-2024-45033 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Fab Provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45033 and fix it if it is affected.

What it is: CVE-2024-45033 is a high-severity vulnerability in Apache Airflow Fab Provider, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45033 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2
- apache-airflow-providers-fab (PyPI): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45033/ (Markdown: https://insights.sbomify.com/CVE-2024-45033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45033
- OSV: https://osv.dev/vulnerability/CVE-2024-45033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45033/
Summaries are generated and may contain mistakes; the official description above is the record.
