# CVE-2024-45034: Apache Airflow: Authenticated DAG authors could execute code on scheduler nodes

> Authenticated DAG authors can execute arbitrary code on scheduler nodes by adding local settings to the DAG folder.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2024
- **Updated:** 9 Sep 2024
- **Also known as:** BIT-airflow-2024-45034, ECHO-5933-7ea4-233c, GHSA-92xg-gmrq-5c3w, PYSEC-2024-212

## What is CVE-2024-45034?

CVE-2024-45034 is a high-severity code injection vulnerability in Apache Airflow, published on 7 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. 
Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2024-45034?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.10.1 |
| `apache-airflow` | PyPI | All versions | 2.10.1 |
| `apache-airflow` | PyPI | All versions | 2.10.1 |
| `airflow` | Bitnami | All versions | 2.10.1 |

Products: Apache Airflow.

## How do I fix CVE-2024-45034?

Upgrade apache-airflow to 2.10.1 or later.

## Is CVE-2024-45034 being exploited?

There is no known exploitation of CVE-2024-45034 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45034 and fix it if it is affected.

What it is: CVE-2024-45034 is a high-severity code injection vulnerability in Apache Airflow, published on 7 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45034 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.10.1
- apache-airflow (PyPI): affected all versions; fixed in 2.10.1
- apache-airflow (PyPI): affected all versions; fixed in 2.10.1
- airflow (Bitnami): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45034/ (Markdown: https://insights.sbomify.com/CVE-2024-45034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45034
- OSV: https://osv.dev/vulnerability/CVE-2024-45034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45034/
Summaries are generated and may contain mistakes; the official description above is the record.
