{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ory/kratos.","exploited":"There is no known exploitation of CVE-2024-45042 in the wild and no public exploit code.","fix":"Upgrade github.com/ory/kratos to 1.3.0 or later.","what":"CVE-2024-45042 is a medium-severity authentication bypass vulnerability in ory kratos, published on 26 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45042 and fix it if it is affected.\n\nWhat it is: CVE-2024-45042 is a medium-severity authentication bypass vulnerability in ory kratos, published on 26 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45042 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ory/kratos (Go): affected all versions; fixed in 1.3.0\n- github.com/ory/kratos (Go): affected all versions; fixed in 1.3.0\n- github.com/ory/kratos (Go): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45042/ (Markdown: https://insights.sbomify.com/CVE-2024-45042/index.md)","id":"CVE-2024-45042","markdown":"https://insights.sbomify.com/CVE-2024-45042/index.md","name":"CVE-2024-45042","record":{"aliases":["GHSA-wc43-73w7-x2f5","GO-2024-3160"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Identity management system","requires_auth":"high_privilege","summary":"Attackers can bypass MFA requirements on specific endpoints by exploiting a logic error in the highest_available setting, allowing unauthorized access with lower assurance levels.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Ory Kratos is an identity, user management and authentication system for cloud services. Prior to version 1.3.0, given a number of preconditions, the `highest_available` setting will incorrectly assume that the identity’s highest available AAL is `aal1` even though it really is `aal2`. This means that the `highest_available` configuration will act as if the user has only one factor set up, for that particular user. This means that they can call the settings and whoami endpoint without a `aal2` session, even though that should be disallowed. An attacker would need to steal or guess a valid login OTP of a user who has only OTP for login enabled and who has an incorrect `available_aal` value stored, to exploit this vulnerability. All other aspects of the session (e.g. the session’s aal) are not impacted by this issue. On the Ory Network, only 0.00066% of registered users were affected by this issue, and most of those users appeared to be test users. Their respective AAL values have since been updated and they are no longer vulnerable to this attack. Version 1.3.0 is not affected by this issue. As a workaround, those who require MFA should disable the passwordless code login method. If that is not possible, check the sessions `aal` to identify if the user has `aal1` or `aal2`.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ory Kratos's `highest_available` setting does not properly respect code + mfa credentials","id":"CVE-2024-45042","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"OpenTelemetry Collector AWS Firehose Receiver Authentication Bypass Vulnerability","id":"CVE-2024-45043"},"packages":[{"ecosystem":"Go","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ory/kratos","purl":null,"source":"GHSA-wc43-73w7-x2f5"},{"ecosystem":"Go","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ory/kratos","purl":"pkg:golang/github.com/ory/kratos","source":"GHSA-wc43-73w7-x2f5"},{"ecosystem":"Go","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ory/kratos","purl":"pkg:golang/github.com/ory/kratos","source":"GO-2024-3160"}],"prev":{"headline":"External Secrets Operator vulnerable to privilege escalation","id":"CVE-2024-45041"},"products":["kratos"],"published":"2024-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-12","vendors":["ory"]},"summary":"Attackers can bypass MFA requirements on specific endpoints by exploiting a logic error in the highest_available setting, allowing unauthorized access with lower assurance levels.","url":"https://insights.sbomify.com/CVE-2024-45042/"}