{"answers":{"affected":"6 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45046 exists.","fix":"Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.1 or 2.1.0.","what":"CVE-2024-45046 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 28 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45046 and fix it if it is affected.\n\nWhat it is: CVE-2024-45046 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 28 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45046 exists.\n\nAffected packages and fixed versions:\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.0\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.0\n- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed\n- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45046/ (Markdown: https://insights.sbomify.com/CVE-2024-45046/index.md)","id":"CVE-2024-45046","markdown":"https://insights.sbomify.com/CVE-2024-45046/index.md","name":"CVE-2024-45046","record":{"aliases":["GHSA-wgmf-q9vr-vww6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"low_privilege","summary":"Attackers can inject JavaScript via spreadsheet styles, leading to session takeover when users view HTML exports.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpspreadsheet","vendor":"phpoffice"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In affected versions `\\PhpOffice\\PhpSpreadsheet\\Writer\\Html` doesn't sanitize spreadsheet styling information such as font names, allowing an attacker to inject arbitrary JavaScript on the page. As a result an attacker may used a crafted spreadsheet to fully takeover a session of a user viewing spreadsheet files as HTML. This issue has been addressed in release version 2.1.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via style information","id":"CVE-2024-45046","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":6,"n_references":3,"next":{"headline":"Potential mXSS vulnerability due to improper HTML escaping in svelte","id":"CVE-2024-45047"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.8.2"],"package":"phpoffice/phpexcel","purl":null,"source":"GHSA-wgmf-q9vr-vww6"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.8.2"],"package":"phpoffice/phpexcel","purl":"pkg:composer/phpoffice/phpexcel","source":"GHSA-wgmf-q9vr-vww6"},{"ecosystem":"Packagist","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-wgmf-q9vr-vww6"},{"ecosystem":"Packagist","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-wgmf-q9vr-vww6"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-wgmf-q9vr-vww6"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-wgmf-q9vr-vww6"}],"prev":{"headline":"JavaScript Injection via url encoded values in links in Collabora Office Android","id":"CVE-2024-45045"},"products":["PhpSpreadsheet"],"published":"2024-08-28","related":[{"cvss_score":9.2,"headline":"PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load","id":"CVE-2026-34084","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":8.8,"headline":"XML External Entity Reference (XXE) in PHPSpreadsheet","id":"CVE-2024-45048","kev_date_added":null,"published":"2024-08-28"},{"cvss_score":8.8,"headline":"XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue","id":"CVE-2019-12331","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":8.8,"headline":"XXE in PHPSpreadsheet due to encoding issue","id":"CVE-2018-19277","kev_date_added":null,"published":"2018-11-14"},{"cvss_score":8.3,"headline":"PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class","id":"CVE-2024-56365","kev_date_added":null,"published":"2025-01-03"},{"cvss_score":8.3,"headline":"PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file","id":"CVE-2024-56366","kev_date_added":null,"published":"2025-01-03"},{"cvss_score":8.3,"headline":"PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file","id":"CVE-2024-56408","kev_date_added":null,"published":"2025-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-29","vendors":["PHPOffice"]},"summary":"Attackers can inject JavaScript via spreadsheet styles, leading to session takeover when users view HTML exports.","url":"https://insights.sbomify.com/CVE-2024-45046/"}