# CVE-2024-45047: Potential mXSS vulnerability due to improper HTML escaping in svelte

> Attackers can execute malicious scripts via mutation XSS in Svelte's server-side rendering due to improper HTML escaping in noscript tags.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2024
- **Updated:** 30 Aug 2024
- **Also known as:** GHSA-8266-84wp-wv5c

## What is CVE-2024-45047?

CVE-2024-45047 is a medium-severity cross-site scripting vulnerability in sveltejs svelte, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

svelte performance oriented web framework. A potential mXSS vulnerability exists in Svelte for versions up to but not including 4.2.19. Svelte improperly escapes HTML on server-side rendering. The assumption is that attributes will always stay as such, but in some situation the final DOM tree rendered on browsers is different from what Svelte expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). More specifically, this can occur when injecting malicious content into an attribute within a `noscript` tag. This issue has been addressed in release version 4.2.19. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-45047?

2 open source packages ship an affected version, including svelte. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `svelte` | npm | All versions | 4.2.19 |
| `svelte` | npm | All versions | 4.2.19 |

Products: Svelte Svelte.

## How do I fix CVE-2024-45047?

Upgrade svelte to 4.2.19 or later.

## Is CVE-2024-45047 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45047 exists.

## Other vulnerabilities in sveltejs svelte

- [CVE-2021-29261](https://insights.sbomify.com/CVE-2021-29261/): Code injection in n/a (high 7.8)
- [CVE-2026-42567](https://insights.sbomify.com/CVE-2026-42567/): Svelte: ReDoS in `<svelte:element>` Tag Validation (medium 5.9)
- [CVE-2022-25875](https://insights.sbomify.com/CVE-2022-25875/): Cross-site Scripting (XSS) (medium 5.4)
- [CVE-2026-42573](https://insights.sbomify.com/CVE-2026-42573/): Svelte: XSS via DOM Clobbering of Internal Framework State (medium 5.3)
- [CVE-2026-27901](https://insights.sbomify.com/CVE-2026-27901/): Svelte vulnerable to XSS during SSR with contenteditable `bind:innerText` and `bind:textContent` (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45047 and fix it if it is affected.

What it is: CVE-2024-45047 is a medium-severity cross-site scripting vulnerability in sveltejs svelte, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45047 exists.

Affected packages and fixed versions:
- svelte (npm): affected all versions; fixed in 4.2.19
- svelte (npm): affected all versions; fixed in 4.2.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45047/ (Markdown: https://insights.sbomify.com/CVE-2024-45047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45047
- OSV: https://osv.dev/vulnerability/CVE-2024-45047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45047/
Summaries are generated and may contain mistakes; the official description above is the record.
