# CVE-2024-45048: XML External Entity Reference (XXE) in PHPSpreadsheet

> An XXE vulnerability in PHPSpreadsheet allows attackers to read local files by bypassing input filters, requiring an upgrade to the latest version.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2024
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-ghg6-32f9-2jp7

## What is CVE-2024-45048?

CVE-2024-45048 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 28 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions are subject to a bypassing of a filter which allows for an XXE-attack. This in turn allows attacker to obtain contents of local files, even if error reporting is muted. This vulnerability has been addressed in release version 2.2.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-45048?

8 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.1 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.2.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.2.1 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2024-45048?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.1, 2.1.1 or 2.2.1.

## Is CVE-2024-45048 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45048 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)
- [CVE-2024-56366](https://insights.sbomify.com/CVE-2024-56366/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45048 and fix it if it is affected.

What it is: CVE-2024-45048 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 28 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45048 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.2.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.2.1
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45048/ (Markdown: https://insights.sbomify.com/CVE-2024-45048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45048
- OSV: https://osv.dev/vulnerability/CVE-2024-45048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45048/
Summaries are generated and may contain mistakes; the official description above is the record.
