# CVE-2024-45051: Bypass of email address validation via encoded email addresses in Discourse

> Attackers can bypass domain restrictions using encoded emails to access private Discourse sites, categories, or groups.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2024
- **Updated:** 8 Oct 2024
- **Also known as:** BIT-discourse-2024-45051, GHSA-2vjv-pgh4-6rmq

## What is CVE-2024-45051?

CVE-2024-45051 is a high-severity authentication bypass vulnerability in Discourse Discourse, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. A maliciously crafted email address could allow an attacker to bypass domain-based restrictions and gain access to private sites, categories and/or groups. This issue has been patched in the latest stable, beta and tests-passed version of Discourse. All users area are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-45051?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.3.2 |

Products: Discourse Discourse.

## How do I fix CVE-2024-45051?

Upgrade discourse to 3.3.2 or later.

## Is CVE-2024-45051 being exploited?

There is no known exploitation of CVE-2024-45051 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45051 and fix it if it is affected.

What it is: CVE-2024-45051 is a high-severity authentication bypass vulnerability in Discourse Discourse, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45051 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45051/ (Markdown: https://insights.sbomify.com/CVE-2024-45051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45051
- OSV: https://osv.dev/vulnerability/CVE-2024-45051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45051/
Summaries are generated and may contain mistakes; the official description above is the record.
