# CVE-2024-45052: Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability

> Unauthenticated attackers can enumerate valid usernames via timing analysis in Fides Webserver, facilitating subsequent credential attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-2h46-8gf5-fmxv, PYSEC-2026-1331

## What is CVE-2024-45052?

CVE-2024-45052 is a medium-severity vulnerability in ethyca fides, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. Prior to version 2.44.0, a timing-based username enumeration vulnerability exists in Fides Webserver authentication. This vulnerability allows an unauthenticated attacker to determine the existence of valid usernames by analyzing the time it takes for the server to respond to login requests. The discrepancy in response times between valid and invalid usernames can be leveraged to enumerate users on the system. This vulnerability enables a timing-based username enumeration attack. An attacker can systematically guess and verify which usernames are valid by measuring the server's response time to authentication requests. This information can be used to conduct further attacks on authentication such as password brute-forcing and credential stuffing. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2024-45052?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.44.0 |
| `ethyca-fides` | PyPI | All versions | 2.44.0 |
| `ethyca-fides` | PyPI | All versions | 2.44.0 |

Products: Ethyca Fides.

## How do I fix CVE-2024-45052?

Upgrade ethyca-fides to 2.44.0 or later.

## Is CVE-2024-45052 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45052 exists.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45052 and fix it if it is affected.

What it is: CVE-2024-45052 is a medium-severity vulnerability in ethyca fides, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45052 exists.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.44.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.44.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45052/ (Markdown: https://insights.sbomify.com/CVE-2024-45052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45052
- OSV: https://osv.dev/vulnerability/CVE-2024-45052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45052/
Summaries are generated and may contain mistakes; the official description above is the record.
