{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45053 exists.","fix":"Upgrade ethyca-fides to 2.44.0 or later.","what":"CVE-2024-45053 is a critical code injection vulnerability in ethyca fides, published on 4 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45053 and fix it if it is affected.\n\nWhat it is: CVE-2024-45053 is a critical code injection vulnerability in ethyca fides, published on 4 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45053 exists.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0\n- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0\n- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45053/ (Markdown: https://insights.sbomify.com/CVE-2024-45053/index.md)","id":"CVE-2024-45053","markdown":"https://insights.sbomify.com/CVE-2024-45053/index.md","name":"CVE-2024-45053","record":{"aliases":["GHSA-c34r-238x-f7qx","PYSEC-2026-1338"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy engineering platform","requires_auth":"high_privilege","summary":"Privileged users can achieve remote code execution via Server-Side Template Injection in the email templating engine.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fides","vendor":"ethyca"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Fides is an open-source privacy engineering platform. Starting in version 2.19.0 and prior to version 2.44.0, the Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default `Owner` or `Contributor` role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine","id":"CVE-2024-45053","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Potential Permission Leakage of Cluster Level in hwameistor","id":"CVE-2024-45054"},"packages":[{"ecosystem":"PyPI","fixed":["2.44.0"],"introduced":["2.19.0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-c34r-238x-f7qx"},{"ecosystem":"PyPI","fixed":["2.44.0"],"introduced":["2.19.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-c34r-238x-f7qx"},{"ecosystem":"PyPI","fixed":["2.44.0"],"introduced":["2.19.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-1338"}],"prev":{"headline":"Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability","id":"CVE-2024-45052"},"products":["fides"],"published":"2024-09-04","related":[{"cvss_score":8.8,"headline":"Remote Code Execution in Custom Integration Upload in Fides","id":"CVE-2023-41319","kev_date_added":null,"published":"2023-09-06"},{"cvss_score":8.6,"headline":"Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation","id":"CVE-2025-57817","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":8.2,"headline":"Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides","id":"CVE-2023-48224","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.2,"headline":"Server-Side Request Forgery Vulnerability in Custom Integration Upload","id":"CVE-2023-46124","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.5,"headline":"Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides","id":"CVE-2024-35189","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-04","vendors":["ethyca"]},"summary":"Privileged users can achieve remote code execution via Server-Side Template Injection in the email templating engine.","url":"https://insights.sbomify.com/CVE-2024-45053/"}