# CVE-2024-45053: Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine

> Privileged users can achieve remote code execution via Server-Side Template Injection in the email templating engine.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-c34r-238x-f7qx, PYSEC-2026-1338

## What is CVE-2024-45053?

CVE-2024-45053 is a critical code injection vulnerability in ethyca fides, published on 4 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. Starting in version 2.19.0 and prior to version 2.44.0, the Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default `Owner` or `Contributor` role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2024-45053?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.44.0 |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.44.0 |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.44.0 |

Products: Ethyca Fides.

## How do I fix CVE-2024-45053?

Upgrade ethyca-fides to 2.44.0 or later.

## Is CVE-2024-45053 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45053 exists.

## Other vulnerabilities in ethyca fides

- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)
- [CVE-2023-36827](https://insights.sbomify.com/CVE-2023-36827/): Fides vulnerable to Path Traversal in Webserver API (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45053 and fix it if it is affected.

What it is: CVE-2024-45053 is a critical code injection vulnerability in ethyca fides, published on 4 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45053 exists.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45053/ (Markdown: https://insights.sbomify.com/CVE-2024-45053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45053
- OSV: https://osv.dev/vulnerability/CVE-2024-45053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45053/
Summaries are generated and may contain mistakes; the official description above is the record.
