# CVE-2024-45216: Apache Solr: Authentication bypass possible using a fake URL Path ending

> Attackers can bypass authentication in Apache Solr by appending a fake path ending to API URLs, allowing unauthorized access to protected resources.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2024
- **Updated:** 8 Nov 2024
- **Also known as:** BIT-solr-2024-45216, GHSA-mjvf-4h88-6xm3, UBUNTU-CVE-2024-45216

## What is CVE-2024-45216?

CVE-2024-45216 is a critical authentication bypass vulnerability in Apache Solr, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Solr.

Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass.
A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path.
This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing.

This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0.

Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-45216?

5 open source packages ship an affected version, including org.apache.solr:solr and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr` | Maven | From 5.3.0 | 8.11.4 |
| `org.apache.solr:solr` | Maven | From 5.3.0 | 8.11.4 |
| `org.apache.solr:solr` | Maven | From 9.0.0 | 9.7.0 |
| `org.apache.solr:solr` | Maven | From 9.0.0 | 9.7.0 |
| `solr` | Bitnami | From 5.3.0 | 8.11.4, 9.7.0 |

Products: Apache Solr.

## How do I fix CVE-2024-45216?

Upgrade org.apache.solr:solr to a fixed version for your release line: 8.11.4 or 9.7.0.

## Is CVE-2024-45216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45216 exists.

Public exploit code:

- https://github.com/congdong007/CVE-2024-45216-Poc (github_poc): https://github.com/congdong007/CVE-2024-45216-Poc
- Apache Solr - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-45216.yaml

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)
- [CVE-2020-13957](https://insights.sbomify.com/CVE-2020-13957/): Incorrect Authorization in Apache Solr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45216 and fix it if it is affected.

What it is: CVE-2024-45216 is a critical authentication bypass vulnerability in Apache Solr, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45216 exists.

Affected packages and fixed versions:
- org.apache.solr:solr (Maven): affected from 5.3.0; fixed in 8.11.4
- org.apache.solr:solr (Maven): affected from 5.3.0; fixed in 8.11.4
- org.apache.solr:solr (Maven): affected from 9.0.0; fixed in 9.7.0
- org.apache.solr:solr (Maven): affected from 9.0.0; fixed in 9.7.0
- solr (Bitnami): affected from 5.3.0; fixed in 8.11.4, 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45216/ (Markdown: https://insights.sbomify.com/CVE-2024-45216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45216
- OSV: https://osv.dev/vulnerability/CVE-2024-45216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45216/
Summaries are generated and may contain mistakes; the official description above is the record.
