CVE-2024-45217 Apache Solr: ConfigSets created during a backup restore command are trusted implicitly
Attackers can restore backups to create trusted ConfigSets without authentication, enabling arbitrary code execution in unsecured Apache Solr instances.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45217?
CVE-2024-45217 is a high-severity vulnerability in Apache Solr, published on 16 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insecure Default Initialization of Resource vulnerability in Apache Solr.
New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized.
This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization.
Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
Weakness: CWE-1188
Which versions are affected by CVE-2024-45217?
5 open source packages ship an affected version, including org.apache.solr:solr and solr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr Maven | From 6.6.0 | 8.11.4 |
org.apache.solr:solr Maven | From 6.6.0 | 8.11.4 |
org.apache.solr:solr Maven | From 9.0.0 | 9.7.0 |
org.apache.solr:solr Maven | From 9.0.0 | 9.7.0 |
solr Bitnami | From 6.6.0 | 8.11.4, 9.7.0 |
Products include Apache Solr.
How do I fix CVE-2024-45217?
Upgrade org.apache.solr:solr to a fixed version for your release line: 8.11.4 or 9.7.0.
Is CVE-2024-45217 being exploited?
There is no known exploitation of CVE-2024-45217 in the wild and no public exploit code.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2024-45217, GHSA-h7w9-c5vx-x7j3, UBUNTU-CVE-2024-45217.