# CVE-2024-45217: Apache Solr: ConfigSets created during a backup restore command are trusted implicitly

> Attackers can restore backups to create trusted ConfigSets without authentication, enabling arbitrary code execution in unsecured Apache Solr instances.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2024
- **Updated:** 16 Oct 2024
- **Also known as:** BIT-solr-2024-45217, GHSA-h7w9-c5vx-x7j3, UBUNTU-CVE-2024-45217

## What is CVE-2024-45217?

CVE-2024-45217 is a high-severity vulnerability in Apache Solr, published on 16 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insecure Default Initialization of Resource vulnerability in Apache Solr.

New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata.
ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request.
"trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized.

This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization.

Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2024-45217?

5 open source packages ship an affected version, including org.apache.solr:solr and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr` | Maven | From 6.6.0 | 8.11.4 |
| `org.apache.solr:solr` | Maven | From 6.6.0 | 8.11.4 |
| `org.apache.solr:solr` | Maven | From 9.0.0 | 9.7.0 |
| `org.apache.solr:solr` | Maven | From 9.0.0 | 9.7.0 |
| `solr` | Bitnami | From 6.6.0 | 8.11.4, 9.7.0 |

Products: Apache Solr.

## How do I fix CVE-2024-45217?

Upgrade org.apache.solr:solr to a fixed version for your release line: 8.11.4 or 9.7.0.

## Is CVE-2024-45217 being exploited?

There is no known exploitation of CVE-2024-45217 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45217 and fix it if it is affected.

What it is: CVE-2024-45217 is a high-severity vulnerability in Apache Solr, published on 16 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45217 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr (Maven): affected from 6.6.0; fixed in 8.11.4
- org.apache.solr:solr (Maven): affected from 6.6.0; fixed in 8.11.4
- org.apache.solr:solr (Maven): affected from 9.0.0; fixed in 9.7.0
- org.apache.solr:solr (Maven): affected from 9.0.0; fixed in 9.7.0
- solr (Bitnami): affected from 6.6.0; fixed in 8.11.4, 9.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45217/ (Markdown: https://insights.sbomify.com/CVE-2024-45217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45217
- OSV: https://osv.dev/vulnerability/CVE-2024-45217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45217/
Summaries are generated and may contain mistakes; the official description above is the record.
