CVE-2024-45230 Django vulnerable to denial-of-service attack via the urlize() and urlizetrunc() template filters

High 7.5 Published Updated

Attackers can cause denial of service in Django applications by sending large inputs to urlize template filters, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-45230?

CVE-2024-45230 is a high-severity denial of service vulnerability in Djangoproject Django, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 5.1 before 5.1.1, 5.0 before 5.0.9, and 4.2 before 4.2.16. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via very large inputs with a specific sequence of characters.

Weakness: CWE-120

Which versions are affected by CVE-2024-45230?

8 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 4.2.04.2.16, 5.0.9, 5.2.5
django PyPIFrom 4.24.2.16
django PyPIFrom 5.05.0.9
django PyPIFrom 5.15.1.1, 5.0.9, 4.2.16
django PyPIFrom 5.15.1.1
Django PyPIFrom 4.24.2.16
2 more packages
Django PyPIFrom 5.05.0.9
Django PyPIFrom 5.15.1.1
Linux distribution packages (1)
python-Django openSUSE:Leap 15.5All versions2.0.7-150000.1.36.1

Products include Djangoproject Django.

How do I fix CVE-2024-45230?

Upgrade django to a fixed version for your release line: 4.2.16, 5.0.9, 5.2.5 or 5.1.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-45230 being exploited?

There is no known exploitation of CVE-2024-45230 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2024-45230, DEBIAN-CVE-2024-45230, GHSA-5hgc-2vfp-mqvc, PYSEC-2024-102, SUSE-SU-2024:3187-1, UBUNTU-CVE-2024-45230.

Is CVE-2024-45230 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free