CVE-2024-45233 Powermail TYPO3 extension Broken Access Control in the OutputController
Unauthenticated attackers can edit, delete, or export form data in TYPO3 Powermail if Frontend plugins are enabled, due to missing access checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-45233?
CVE-2024-45233 is a high-severity missing authorization vulnerability in n/a, published on 28 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
Weakness: CWE-284
Which versions are affected by CVE-2024-45233?
8 open source packages ship an affected version, including in2code/powermail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
in2code/powermail Packagist | All versions | 7.5.0 |
in2code/powermail Packagist | All versions | 7.5.0 |
in2code/powermail Packagist | From 11.0.0 | 12.4.0 |
in2code/powermail Packagist | From 11.0.0 | 12.4.0 |
in2code/powermail Packagist | From 8.0.0 | 8.5.0 |
in2code/powermail Packagist | From 8.0.0 | 8.5.0 |
2 more packages
in2code/powermail Packagist | From 9.0.0 | 10.9.0 |
in2code/powermail Packagist | From 9.0.0 | 10.9.0 |
Products include In2code Powermail.
How do I fix CVE-2024-45233?
Upgrade in2code/powermail to a fixed version for your release line: 7.5.0, 12.4.0, 8.5.0 or 10.9.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-45233 being exploited?
There is no known exploitation of CVE-2024-45233 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-9jqr-5x45-pgw8.