# CVE-2024-45233: Powermail TYPO3 extension Broken Access Control in the OutputController

> Unauthenticated attackers can edit, delete, or export form data in TYPO3 Powermail if Frontend plugins are enabled, due to missing access checks.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2024
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-9jqr-5x45-pgw8

## What is CVE-2024-45233?

CVE-2024-45233 is a high-severity missing authorization vulnerability in n/a, published on 28 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-45233?

8 open source packages ship an affected version, including in2code/powermail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/powermail` | Packagist | All versions | 7.5.0 |
| `in2code/powermail` | Packagist | All versions | 7.5.0 |
| `in2code/powermail` | Packagist | From 11.0.0 | 12.4.0 |
| `in2code/powermail` | Packagist | From 11.0.0 | 12.4.0 |
| `in2code/powermail` | Packagist | From 8.0.0 | 8.5.0 |
| `in2code/powermail` | Packagist | From 8.0.0 | 8.5.0 |
| `in2code/powermail` | Packagist | From 9.0.0 | 10.9.0 |
| `in2code/powermail` | Packagist | From 9.0.0 | 10.9.0 |

Products: In2code Powermail.

## How do I fix CVE-2024-45233?

Upgrade in2code/powermail to a fixed version for your release line: 7.5.0, 12.4.0, 8.5.0 or 10.9.0.

## Is CVE-2024-45233 being exploited?

There is no known exploitation of CVE-2024-45233 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-47047](https://insights.sbomify.com/CVE-2024-47047/): powermail TYPO3 extension has Insecure Direct Object Reference (high 7.5)
- [CVE-2024-45232](https://insights.sbomify.com/CVE-2024-45232/): "powermail" (powermail) Insecure Direct Object Reference (IDOR) (high 7.3)
- [CVE-2008-2182](https://insights.sbomify.com/CVE-2008-2182/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45233 and fix it if it is affected.

What it is: CVE-2024-45233 is a high-severity missing authorization vulnerability in n/a, published on 28 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45233 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/powermail (Packagist): affected all versions; fixed in 7.5.0
- in2code/powermail (Packagist): affected all versions; fixed in 7.5.0
- in2code/powermail (Packagist): affected from 11.0.0; fixed in 12.4.0
- in2code/powermail (Packagist): affected from 11.0.0; fixed in 12.4.0
- in2code/powermail (Packagist): affected from 8.0.0; fixed in 8.5.0
- in2code/powermail (Packagist): affected from 8.0.0; fixed in 8.5.0
- in2code/powermail (Packagist): affected from 9.0.0; fixed in 10.9.0
- in2code/powermail (Packagist): affected from 9.0.0; fixed in 10.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45233/ (Markdown: https://insights.sbomify.com/CVE-2024-45233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45233
- OSV: https://osv.dev/vulnerability/CVE-2024-45233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45233/
Summaries are generated and may contain mistakes; the official description above is the record.
