# CVE-2024-45244: Hyperledger Fabric does not verify request has a timestamp within the expected time window

> Attackers can bypass timestamp verification in Hyperledger Fabric, potentially replaying requests or manipulating transaction ordering.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2024
- **Updated:** 6 Oct 2025
- **Also known as:** BIT-hyperledger-fabric-orderer-2024-45244, BIT-hyperledger-fabric-peer-2024-45244, BIT-hyperledger-fabric-tools-2024-45244, GHSA-48gg-32q2-4r6m, GO-2024-3099

## What is CVE-2024-45244?

CVE-2024-45244 is a medium-severity vulnerability in n/a, published on 25 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has a timestamp within the expected time window.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2024-45244?

6 open source packages ship an affected version, including github.com/hyperledger/fabric, hyperledger-fabric-orderer and hyperledger-fabric-peer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hyperledger/fabric` | Go | All versions | None |
| `github.com/hyperledger/fabric` | Go | All versions to 2.5.9 | None |
| `github.com/hyperledger/fabric` | Go | All versions to 2.5.9 | None |
| `hyperledger-fabric-orderer` | Bitnami | All versions | 2.5.10 |
| `hyperledger-fabric-peer` | Bitnami | All versions | 2.5.10 |
| `hyperledger-fabric-tools` | Bitnami | All versions | 2.5.10 |

Products: Hyperledger Fabric.

## How do I fix CVE-2024-45244?

Upgrade to a fixed version.

## Is CVE-2024-45244 being exploited?

There is no known exploitation of CVE-2024-45244 in the wild and no public exploit code.

Public exploit code:

- Chaincode for blockchain Hyperledger Fabric provides accurate time to other chaincodes. Thus solving the security problem associated with transaction time manipulation (CVE-2024-45244). (github_poc): https://github.com/shanker-sec/hlf-time-oracle
- PoC covering the problem of transaction time manipulation (CVE-2024-45244) in the Hyperledger Fabric blockchain. (github_poc): https://github.com/shanker-sec/HLF_TxTime_spoofing

## Other vulnerabilities in n/a

- [CVE-2026-41586](https://insights.sbomify.com/CVE-2026-41586/): ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE (critical 9.3)
- [CVE-2022-45196](https://insights.sbomify.com/CVE-2022-45196/): Denial of service in n/a (high 7.5)
- [CVE-2022-31121](https://insights.sbomify.com/CVE-2022-31121/): Improper Input Validation in fabric hyperledger (high 7.5)
- [CVE-2023-46132](https://insights.sbomify.com/CVE-2023-46132/): Crosslinking transaction attack in hyperledger/fabric (high 7.1)
- [CVE-2022-36023](https://insights.sbomify.com/CVE-2022-36023/): Remote denial of service in Hyperledger Fabric Gateway (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45244 and fix it if it is affected.

What it is: CVE-2024-45244 is a medium-severity vulnerability in n/a, published on 25 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45244 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hyperledger/fabric (Go): affected all versions; no fix listed
- github.com/hyperledger/fabric (Go): affected all versions up to 2.5.9; no fix listed
- github.com/hyperledger/fabric (Go): affected all versions up to 2.5.9; no fix listed
- hyperledger-fabric-orderer (Bitnami): affected all versions; fixed in 2.5.10
- hyperledger-fabric-peer (Bitnami): affected all versions; fixed in 2.5.10
- hyperledger-fabric-tools (Bitnami): affected all versions; fixed in 2.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45244/ (Markdown: https://insights.sbomify.com/CVE-2024-45244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45244
- OSV: https://osv.dev/vulnerability/CVE-2024-45244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45244/
Summaries are generated and may contain mistakes; the official description above is the record.
