# CVE-2024-45277: Prototype Pollution vulnerability in SAP HANA Client

> Attackers can cause denial of service via prototype pollution in the SAP HANA Node.js client when using the nestTables feature.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-6339-gv7w-g5f4

## What is CVE-2024-45277?

CVE-2024-45277 is a medium-severity vulnerability in SAP_SE SAP HANA Client, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The SAP HANA Node.js client package versions from 2.0.0 before 2.21.31 is impacted by Prototype Pollution vulnerability allowing an attacker to add arbitrary properties to global object prototypes. This is due to improper user input sanitation when using the nestTables feature causing low impact on the availability of the application. This has no impact on Confidentiality and Integrity.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-45277?

2 open source packages ship an affected version, including @sap/hana-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sap/hana-client` | npm | From 2.0.0 | 2.21.31 |
| `@sap/hana-client` | npm | From 2.0.0 | 2.21.31 |

Products: Sap Hana-Client.

## How do I fix CVE-2024-45277?

Upgrade @sap/hana-client to 2.21.31 or later.

## Is CVE-2024-45277 being exploited?

There is no known exploitation of CVE-2024-45277 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45277 and fix it if it is affected.

What it is: CVE-2024-45277 is a medium-severity vulnerability in SAP_SE SAP HANA Client, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45277 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sap/hana-client (npm): affected from 2.0.0; fixed in 2.21.31
- @sap/hana-client (npm): affected from 2.0.0; fixed in 2.21.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45277/ (Markdown: https://insights.sbomify.com/CVE-2024-45277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45277
- OSV: https://osv.dev/vulnerability/CVE-2024-45277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45277/
Summaries are generated and may contain mistakes; the official description above is the record.
