# CVE-2024-45291: Path traversal and Server-Side Request Forgery in HTML writer when embedding images is enabled in PHPSpreadsheet

> Attackers can read arbitrary files and execute code via SSRF in PHPSpreadsheet when image embedding is enabled in the HTML writer.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2024
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-w9xv-qf98-ccq4

## What is CVE-2024-45291?

CVE-2024-45291 is a medium-severity path traversal vulnerability in PHPOffice PhpSpreadsheet, published on 7 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file that links images from arbitrary paths. When embedding images has been enabled in HTML writer with `$writer->setEmbedImages(true);` those files will be included in the output as `data:` URLs, regardless of the file's type. Also URLs can be used for embedding, resulting in a Server-Side Request Forgery vulnerability. When embedding images has been enabled, an attacker can read arbitrary files on the server and perform arbitrary HTTP GET requests. Note that any PHP protocol wrappers can be used, meaning that if for example the `expect://` wrapper is enabled, also remote code execution is possible. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. there are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-918 (Server-Side Request Forgery), CWE-36 (Absolute Path Traversal)

## Which versions are affected by CVE-2024-45291?

8 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.2 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.2 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.0 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2024-45291?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.2, 2.1.1 or 2.3.0.

## Is CVE-2024-45291 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45291 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45291 and fix it if it is affected.

What it is: CVE-2024-45291 is a medium-severity path traversal vulnerability in PHPOffice PhpSpreadsheet, published on 7 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45291 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.2
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.2
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.0
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45291/ (Markdown: https://insights.sbomify.com/CVE-2024-45291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45291
- OSV: https://osv.dev/vulnerability/CVE-2024-45291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45291/
Summaries are generated and may contain mistakes; the official description above is the record.
