# CVE-2024-45293: XML External Entity Reference (XXE) in PHPSpreadsheet's XLSX reader

> Attackers can disclose sensitive server files by uploading crafted XLSX files to applications using PHPSpreadsheet, bypassing XML security checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2024
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-6hwr-6v2f-3m88

## What is CVE-2024-45293?

CVE-2024-45293 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. The security scanner responsible for preventing XXE attacks in the XLSX reader can be bypassed by slightly modifying the XML structure, utilizing white-spaces. On servers that allow users to upload their own Excel (XLSX) sheets, Server files and sensitive information can be disclosed by providing a crafted sheet. The security scan function in src/PhpSpreadsheet/Reader/Security/XmlScanner.php contains a flawed XML encoding check to retrieve the input file's XML encoding in the toUtf8 function. The function searches for the XML encoding through a defined regex which looks for `encoding="*"` and/or `encoding='*'`, if not found, it defaults to the UTF-8 encoding which bypasses the conversion logic. This logic can be used to pass a UTF-7 encoded XXE payload, by utilizing a whitespace before or after the = in the attribute definition. Sensitive information disclosure through the XXE on sites that allow users to upload their own excel spreadsheets, and parse them using PHPSpreadsheet's Excel parser. This issue has been addressed in release versions 1.29.1, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-45293?

8 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.1 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.1 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.0 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2024-45293?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.1, 2.1.1 or 2.3.0.

## Is CVE-2024-45293 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45293 exists.

Public exploit code:

- TablePress < 2.4.3 - XXE Injection (nuclei): http/cves/2024/CVE-2024-45293.yaml

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45293 and fix it if it is affected.

What it is: CVE-2024-45293 is a high-severity vulnerability in PHPOffice PhpSpreadsheet, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45293 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.1
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.0
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45293/ (Markdown: https://insights.sbomify.com/CVE-2024-45293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45293
- OSV: https://osv.dev/vulnerability/CVE-2024-45293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45293/
Summaries are generated and may contain mistakes; the official description above is the record.
