# CVE-2024-45294: `org.hl7.fhir.core` XXE vulnerability in XSLT transforms

> An attacker can read host system data via XML external entity injection in XSLT transforms within the HL7 FHIR Core library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2024
- **Updated:** 6 Sep 2024
- **Also known as:** CVE-2024-45295, GHSA-6cr6-ph3p-f5rf, ROOT-APP-MAVEN-CVE-2024-45294

## What is CVE-2024-45294?

CVE-2024-45294 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 6 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The HL7 FHIR Core Artifacts repository provides the java core object handling code, with utilities (including validator), for the Fast Healthcare Interoperability Resources (FHIR) specification. Prior to version 6.3.23, XSLT transforms performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. This issue has been patched in release 6.3.23. No known workarounds are available.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-45294?

12 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may, ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 and ca.uhn.hapi.fhir:org.hl7.fhir.r4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.3.23 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.3.23 |

## How do I fix CVE-2024-45294?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may to 6.3.23 or later.

## Is CVE-2024-45294 being exploited?

There is no known exploitation of CVE-2024-45294 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45294 and fix it if it is affected.

What it is: CVE-2024-45294 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 6 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45294 in the wild and no public exploit code.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.3.23
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.3.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45294/ (Markdown: https://insights.sbomify.com/CVE-2024-45294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45294
- OSV: https://osv.dev/vulnerability/CVE-2024-45294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45294/
Summaries are generated and may contain mistakes; the official description above is the record.
