{"answers":{"affected":"3 open source packages ship an affected version, including gix-path.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45305 exists.","fix":"Upgrade gix-path to 0.10.10 or later.","what":"CVE-2024-45305 is a low-severity vulnerability in Byron gitoxide, published on 2 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45305 and fix it if it is affected.\n\nWhat it is: CVE-2024-45305 is a low-severity vulnerability in Byron gitoxide, published on 2 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45305 exists.\n\nAffected packages and fixed versions:\n- gix-path (crates.io): affected all versions; fixed in 0.10.10\n- gix-path (crates.io): affected all versions; fixed in 0.10.10\n- gix-path (crates.io): affected from 0.0.0-0; fixed in 0.10.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45305/ (Markdown: https://insights.sbomify.com/CVE-2024-45305/index.md)","id":"CVE-2024-45305","markdown":"https://insights.sbomify.com/CVE-2024-45305/index.md","name":"CVE-2024-45305","record":{"aliases":["CVE-2024-8371","DEBIAN-CVE-2024-45305","GHSA-v26r-4c9c-h3j6","RUSTSEC-2024-0367","UBUNTU-CVE-2024-45305"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Rust git library","requires_auth":"none","summary":"A flaw in gix-path may leak sensitive credentials or treat untrusted repositories as trusted due to incorrect configuration scope handling.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-706","name":"Use of Incorrectly-Resolved Name or Reference"}],"description":"gix-path is a crate of the gitoxide project dealing with git paths and their conversions. `gix-path` executes `git` to find the path of a configuration file that belongs to the `git` installation itself, but mistakenly treats the local repository's configuration as system-wide if no higher scoped configuration is found. In rare cases, this causes a less trusted repository to be treated as more trusted, or leaks sensitive information from one repository to another, such as sending credentials to another repository's remote. In `gix_path::env`, the underlying implementation of the `installation_config` and `installation_config_prefix` functions calls `git config -l --show-origin` and parses the first line of the output to extract the path to the configuration file holding the configuration variable of highest scope. It is believed to be very difficult to exploit this vulnerability deliberately, due to the need either to anticipate a situation in which higher-scoped configuration variables would be absent, or to arrange for this to happen. Although any operating system may be affected, users running Apple Git on macOS are much less likely to be affected. This issue has been addressed in release version 0.10.10. All users are advised to upgrade.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"gix-path uses local config across repos when it is the highest scope","id":"CVE-2024-45305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"heap-buffer-overflow in Vim","id":"CVE-2024-45306"},"packages":[{"ecosystem":"crates.io","fixed":["0.10.10"],"introduced":["0"],"last_affected":[],"package":"gix-path","purl":null,"source":"GHSA-v26r-4c9c-h3j6"},{"ecosystem":"crates.io","fixed":["0.10.10"],"introduced":["0"],"last_affected":[],"package":"gix-path","purl":"pkg:cargo/gix-path","source":"GHSA-v26r-4c9c-h3j6"},{"ecosystem":"crates.io","fixed":["0.10.10"],"introduced":["0.0.0-0"],"last_affected":[],"package":"gix-path","purl":"pkg:cargo/gix-path","source":"RUSTSEC-2024-0367"}],"prev":{"headline":"Business logic in cairo-contracts","id":"CVE-2024-45304"},"products":["gitoxide"],"published":"2024-09-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["Byron"]},"summary":"A flaw in gix-path may leak sensitive credentials or treat untrusted repositories as trusted due to incorrect configuration scope handling.","url":"https://insights.sbomify.com/CVE-2024-45305/"}