{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45312 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-45312 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-45312 is a medium-severity path traversal vulnerability in overleaf, published on 2 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45312 and fix it if it is affected.\n\nWhat it is: CVE-2024-45312 is a medium-severity path traversal vulnerability in overleaf, published on 2 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45312 in the wild and no public exploit code.\n\nAffected product: overleaf. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45312/ (Markdown: https://insights.sbomify.com/CVE-2024-45312/index.md)","id":"CVE-2024-45312","markdown":"https://insights.sbomify.com/CVE-2024-45312/index.md","name":"CVE-2024-45312","record":{"aliases":["GHSA-pxm4-p454-vppg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Overleaf LaTeX editor","requires_auth":"none","summary":"Attackers can manipulate language parameters to force the server to load arbitrary dictionary files, potentially exposing sensitive data within the server scope.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"overleaf","vendor":"overleaf"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-641","name":"Improper Restriction of Names for Files and Other Resources"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server.  This causes `aspell` to attempt to load  a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7.  Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature.  However, upgrading is advised.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf","id":"CVE-2024-45312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Insecure default setting for Server Pro installed via Overleaf toolkit","id":"CVE-2024-45313"},"packages":[],"prev":{"headline":"Denial of service in quinn-proto when using `Endpoint::retry()`","id":"CVE-2024-45311"},"products":["overleaf"],"published":"2024-09-02","related":[{"cvss_score":5.4,"headline":"Insecure default setting for Server Pro installed via Overleaf toolkit","id":"CVE-2024-45313","kev_date_added":null,"published":"2024-09-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["overleaf"]},"summary":"Attackers can manipulate language parameters to force the server to load arbitrary dictionary files, potentially exposing sensitive data within the server scope.","url":"https://insights.sbomify.com/CVE-2024-45312/"}