# CVE-2024-45314: Flask-AppBuilder login form allows browser to cache sensitive fields

> An attacker with access to a shared computer can retrieve sensitive login data cached by the browser due to missing cache-control headers in Flask-AppBuilder.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 4 Sep 2024
- **Also known as:** ECHO-4cf8-1d7b-5c06, GHSA-fw5r-6m3x-rh7p, PYSEC-2026-1382

## What is CVE-2024-45314?

CVE-2024-45314 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 4 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Flask-AppBuilder is an application development framework. Prior to version 4.5.1, the auth DB login form default cache directives allows browser to locally store sensitive data. This can be an issue on environments using shared computer resources. Version 4.5.1 contains a patch for this issue. If upgrading is not possible, configure one's web server to send the specific HTTP headers for `/login` per the directions provided in the GitHub Security Advisory.

Weakness: CWE-525 (Use of Web Browser Cache Containing Sensitive Information)

## Which versions are affected by CVE-2024-45314?

3 open source packages ship an affected version, including flask-appbuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.5.1 |
| `flask-appbuilder` | PyPI | All versions | 4.5.1 |
| `flask-appbuilder` | PyPI | All versions | 4.5.1 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2024-45314?

Upgrade flask-appbuilder to 4.5.1 or later.

## Is CVE-2024-45314 being exploited?

There is no known exploitation of CVE-2024-45314 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45314 and fix it if it is affected.

What it is: CVE-2024-45314 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 4 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45314 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.1
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.1
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45314/ (Markdown: https://insights.sbomify.com/CVE-2024-45314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45314
- OSV: https://osv.dev/vulnerability/CVE-2024-45314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45314/
Summaries are generated and may contain mistakes; the official description above is the record.
