{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.druid.extensions:druid-pac4j. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45384 in the wild and no public exploit code.","fix":"Upgrade org.apache.druid.extensions:druid-pac4j to 30.0.1 or later.","what":"CVE-2024-45384 is a medium-severity vulnerability in Apache Druid, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45384 and fix it if it is affected.\n\nWhat it is: CVE-2024-45384 is a medium-severity vulnerability in Apache Druid, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-45384 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.druid.extensions:druid-pac4j (Maven): affected from 0.18.0; fixed in 30.0.1\n- org.apache.druid.extensions:druid-pac4j (Maven): affected from 0.18.0; fixed in 30.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45384/ (Markdown: https://insights.sbomify.com/CVE-2024-45384/index.md)","id":"CVE-2024-45384","markdown":"https://insights.sbomify.com/CVE-2024-45384/index.md","name":"CVE-2024-45384","record":{"aliases":["GHSA-p72w-r6fv-6g5h"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Druid","requires_auth":"none","summary":"An attacker can manipulate pac4j session cookies in Apache Druid via a padding oracle attack if the optional druid-pac4j extension is enabled.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"druid","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Padding Oracle vulnerability in Apache Druid extension, druid-pac4j.\nThis could allow an attacker to manipulate a pac4j session cookie.\n\nThis issue affects Apache Druid versions 0.18.0 through 30.0.0.\nSince the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability.\n\nWhile we are not aware of a way to meaningfully exploit this flaw, we \nnevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue\nand ensuring you have a strong \ndruid.auth.pac4j.cookiePassphrase as a precaution.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability","id":"CVE-2024-45384","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in Industrial Edge Management OS (IEM-OS)","id":"CVE-2024-45385"},"packages":[{"ecosystem":"Maven","fixed":["30.0.1"],"introduced":["0.18.0"],"last_affected":[],"package":"org.apache.druid.extensions:druid-pac4j","purl":null,"source":"GHSA-p72w-r6fv-6g5h"},{"ecosystem":"Maven","fixed":["30.0.1"],"introduced":["0.18.0"],"last_affected":[],"package":"org.apache.druid.extensions:druid-pac4j","purl":"pkg:maven/org.apache.druid.extensions/druid-pac4j","source":"GHSA-p72w-r6fv-6g5h"}],"prev":{"headline":"Denial of service in HDAudBus.sys","id":"CVE-2024-45383"},"products":["Apache Druid"],"published":"2024-09-17","related":[{"cvss_score":9.8,"headline":"Apache Druid: Authentication Bypass via LDAP Anonymous Bind","id":"CVE-2026-23906","kev_date_added":null,"published":"2026-02-10"},{"cvss_score":9.8,"headline":"Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly.","id":"CVE-2025-59390","kev_date_added":null,"published":"2025-11-26"},{"cvss_score":8.8,"headline":"Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems.","id":"CVE-2021-26919","kev_date_added":null,"published":"2021-03-30"},{"cvss_score":8.8,"headline":"Authenticated users can override system configurations in their requests which allows them to execute arbitrary code.","id":"CVE-2021-25646","kev_date_added":null,"published":"2021-01-29"},{"cvss_score":6.5,"headline":"Apache Druid: Users can provide MySQL JDBC properties not on allow list","id":"CVE-2024-45537","kev_date_added":null,"published":"2024-09-17"},{"cvss_score":6.5,"headline":"Druid ingestion system Authenticated users can read data from other sources than intended","id":"CVE-2021-36749","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":6.5,"headline":"Apache Druid: The HTTP inputSource allows authenticated users to read data from other sources than intended","id":"CVE-2021-26920","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-14","vendors":["Apache Software Foundation"]},"summary":"An attacker can manipulate pac4j session cookies in Apache Druid via a padding oracle attack if the optional druid-pac4j extension is enabled.","url":"https://insights.sbomify.com/CVE-2024-45384/"}