# CVE-2024-45384: druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability

> An attacker can manipulate pac4j session cookies in Apache Druid via a padding oracle attack if the optional druid-pac4j extension is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 14 Mar 2025
- **Also known as:** GHSA-p72w-r6fv-6g5h

## What is CVE-2024-45384?

CVE-2024-45384 is a medium-severity vulnerability in Apache Druid, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j.
This could allow an attacker to manipulate a pac4j session cookie.

This issue affects Apache Druid versions 0.18.0 through 30.0.0.
Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability.

While we are not aware of a way to meaningfully exploit this flaw, we 
nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue
and ensuring you have a strong 
druid.auth.pac4j.cookiePassphrase as a precaution.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2024-45384?

2 open source packages ship an affected version, including org.apache.druid.extensions:druid-pac4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.druid.extensions:druid-pac4j` | Maven | From 0.18.0 | 30.0.1 |
| `org.apache.druid.extensions:druid-pac4j` | Maven | From 0.18.0 | 30.0.1 |

Products: Apache Druid.

## How do I fix CVE-2024-45384?

Upgrade org.apache.druid.extensions:druid-pac4j to 30.0.1 or later.

## Is CVE-2024-45384 being exploited?

There is no known exploitation of CVE-2024-45384 in the wild and no public exploit code.

## Other vulnerabilities in Apache Druid

- [CVE-2026-23906](https://insights.sbomify.com/CVE-2026-23906/): Apache Druid: Authentication Bypass via LDAP Anonymous Bind (critical 9.8)
- [CVE-2025-59390](https://insights.sbomify.com/CVE-2025-59390/): Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. (critical 9.8)
- [CVE-2021-26919](https://insights.sbomify.com/CVE-2021-26919/): Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. (high 8.8)
- [CVE-2021-25646](https://insights.sbomify.com/CVE-2021-25646/): Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. (high 8.8)
- [CVE-2024-45537](https://insights.sbomify.com/CVE-2024-45537/): Apache Druid: Users can provide MySQL JDBC properties not on allow list (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45384 and fix it if it is affected.

What it is: CVE-2024-45384 is a medium-severity vulnerability in Apache Druid, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45384 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.druid.extensions:druid-pac4j (Maven): affected from 0.18.0; fixed in 30.0.1
- org.apache.druid.extensions:druid-pac4j (Maven): affected from 0.18.0; fixed in 30.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45384/ (Markdown: https://insights.sbomify.com/CVE-2024-45384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45384
- OSV: https://osv.dev/vulnerability/CVE-2024-45384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45384/
Summaries are generated and may contain mistakes; the official description above is the record.
