# CVE-2024-45388: Arbitrary file read in the `/api/v2/simulation` endpoint in hoverfly (`GHSL-2023-274`)

> An attacker can read arbitrary files from the Hoverfly server by exploiting path traversal in the simulation API endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2024
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-6xx4-x46f-f897, GO-2024-3108

## What is CVE-2024-45388?

CVE-2024-45388 is a high-severity path traversal vulnerability in SpectoLabs hoverfly, published on 2 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hoverfly is a lightweight service virtualization/ API simulation / API mocking tool for developers and testers. The `/api/v2/simulation` POST handler allows users to create new simulation views from the contents of a user-specified file. This feature can be abused by an attacker to read arbitrary files from the Hoverfly server. Note that, although the code prevents absolute paths from being specified, an attacker can escape out of the `hf.Cfg.ResponsesBodyFilesPath` base path by using `../` segments and reach any arbitrary files. This issue was found using the Uncontrolled data used in path expression CodeQL query for python. Users are advised to make sure the final path (`filepath.Join(hf.Cfg.ResponsesBodyFilesPath, filePath)`) is contained within the expected base path (`filepath.Join(hf.Cfg.ResponsesBodyFilesPath, "/")`). This issue is also tracked as GHSL-2023-274.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-45388?

5 open source packages ship an affected version, including github.com/SpectoLabs/hoverfly and github.com/spectolabs/hoverfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/SpectoLabs/hoverfly` | Go | All versions | 1.10.3 |
| `github.com/SpectoLabs/hoverfly` | Go | All versions | 1.10.3 |
| `github.com/SpectoLabs/hoverfly` | Go | All versions | 1.10.3 |
| `github.com/spectolabs/hoverfly` | Go | All versions | 1.10.3 |
| `github.com/spectolabs/hoverfly` | Go | All versions | 1.10.3 |

Products: Hoverfly Hoverfly.

## How do I fix CVE-2024-45388?

Upgrade github.com/SpectoLabs/hoverfly to 1.10.3 or later.

## Is CVE-2024-45388 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45388 exists.

Public exploit code:

- Hoverfly < 1.10.3 - Arbitrary File Read (nuclei): http/cves/2024/CVE-2024-45388.yaml

## Other vulnerabilities in SpectoLabs hoverfly

- [CVE-2025-54123](https://insights.sbomify.com/CVE-2025-54123/): Hoverfly is vulnerable to Remote Code Execution through an insecure middleware implementation (critical 9.8)
- [CVE-2025-54376](https://insights.sbomify.com/CVE-2025-54376/): Hoverfly's WebSocket endpoint `/api/v2/ws/logs` reachable without authentication even when --auth is enabled. (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45388 and fix it if it is affected.

What it is: CVE-2024-45388 is a high-severity path traversal vulnerability in SpectoLabs hoverfly, published on 2 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45388 exists.

Affected packages and fixed versions:
- github.com/SpectoLabs/hoverfly (Go): affected all versions; fixed in 1.10.3
- github.com/SpectoLabs/hoverfly (Go): affected all versions; fixed in 1.10.3
- github.com/SpectoLabs/hoverfly (Go): affected all versions; fixed in 1.10.3
- github.com/spectolabs/hoverfly (Go): affected all versions; fixed in 1.10.3
- github.com/spectolabs/hoverfly (Go): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45388/ (Markdown: https://insights.sbomify.com/CVE-2024-45388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45388
- OSV: https://osv.dev/vulnerability/CVE-2024-45388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45388/
Summaries are generated and may contain mistakes; the official description above is the record.
