CVE-2024-4539 Allocation of Resources Without Limits or Throttling in GitLab

Medium 4.3 Published Updated

Attackers can cause a Denial of Service in GitLab by abusing the API to filter branches and tags, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-4539?

CVE-2024-4539 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 prior to 16.9.7, starting from 16.10 prior to 16.10.5, and starting from 16.11 prior to 16.11.2 where abusing the API to filter branch and tags could lead to Denial of Service.

Weakness: CWE-770

Which versions are affected by CVE-2024-4539?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.4.016.9.7, 16.10.5, 16.11.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-4539?

Upgrade gitlab to a fixed version for your release line: 16.9.7, 16.10.5 or 16.11.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-4539 being exploited?

There is no known exploitation of CVE-2024-4539 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-4539, GHSA-2qhw-5384-m8g2, UBUNTU-CVE-2024-4539.

Is CVE-2024-4539 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free