CVE-2024-45392 SuiteCRM has wrong deletion permission checks on API delete call

High 7.7 Published Updated

Attackers can delete records via the API due to insufficient access control checks in SuiteCRM.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-45392?

CVE-2024-45392 is a high-severity missing authorization vulnerability in Salesagility Suitecrm, published on 5 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SuiteCRM is an open-source customer relationship management (CRM) system. Prior to version 7.14.5 and 8.6.2, insufficient access control checks allow a threat actor to delete records via the API. Versions 7.14.5 and 8.6.2 contain a patch for the issue.

Weakness: CWE-284

Which versions are affected by CVE-2024-45392?

1 open source package ship an affected version, including suitecrm. It affects 1 product.

PackageAffectedFixed in
suitecrm BitnamiAll versions7.14.5, 8.6.2

Products include Salesagility Suitecrm.

How do I fix CVE-2024-45392?

Upgrade suitecrm to a fixed version for your release line: 7.14.5 or 8.6.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-45392 being exploited?

There is no known exploitation of CVE-2024-45392 in the wild and no public exploit code.

All Salesagility Suitecrm vulnerabilities

Sources

Also known as BIT-suitecrm-2024-45392, GHSA-8qfx-h7pm-2587.

Is CVE-2024-45392 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free