# CVE-2024-45395: Unbounded loop over untrusted input can lead to endless data attack

> Attackers can cause denial of service in applications using sigstore-go by submitting maliciously crafted bundles with excessive verifiable data.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 5 Sep 2024
- **Also known as:** GHSA-cq38-jh5f-37mq, GO-2024-3116

## What is CVE-2024-45395?

CVE-2024-45395 is a low-severity denial of service vulnerability in sigstore-go, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

sigstore-go, a Go library for Sigstore signing and verification, is susceptible to a denial of service attack in versions prior to 0.6.1 when a verifier is provided a maliciously crafted Sigstore Bundle containing large amounts of verifiable data, in the form of signed transparency log entries, RFC 3161 timestamps, and attestation subjects. The verification of these data structures is computationally expensive. This can be used to consume excessive CPU resources, leading to a denial of service attack. TUF's security model labels this type of vulnerability an "Endless data attack," and can lead to verification failing to complete and disrupting services that rely on sigstore-go for verification. This vulnerability is addressed with sigstore-go 0.6.1, which adds hard limits to the number of verifiable data structures that can be processed in a bundle. Verification will fail if a bundle has data that exceeds these limits. The limits are 32 signed transparency log entries, 32 RFC 3161 timestamps, 1024 attestation subjects, and 32 digests per attestation subject. These limits are intended to be high enough to accommodate the vast majority of use cases, while preventing the verification of maliciously crafted bundles that contain large amounts of verifiable data. Users who are vulnerable but unable to quickly upgrade may consider adding manual bundle validation to enforce limits similar to those in the referenced patch prior to calling sigstore-go's verification functions.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-45395?

3 open source packages ship an affected version, including github.com/sigstore/sigstore-go. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/sigstore-go` | Go | All versions | 0.6.1 |
| `github.com/sigstore/sigstore-go` | Go | All versions | 0.6.1 |
| `github.com/sigstore/sigstore-go` | Go | All versions | 0.6.1 |

Products: Sigstore Sigstore-Go.

## How do I fix CVE-2024-45395?

Upgrade github.com/sigstore/sigstore-go to 0.6.1 or later.

## Is CVE-2024-45395 being exploited?

There is no known exploitation of CVE-2024-45395 in the wild and no public exploit code.

## Other vulnerabilities in sigstore-go

- [CVE-2026-49834](https://insights.sbomify.com/CVE-2026-49834/): sigstore-go: Multi-log threshold bypass via single compromised log (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45395 and fix it if it is affected.

What it is: CVE-2024-45395 is a low-severity denial of service vulnerability in sigstore-go, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45395 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/sigstore-go (Go): affected all versions; fixed in 0.6.1
- github.com/sigstore/sigstore-go (Go): affected all versions; fixed in 0.6.1
- github.com/sigstore/sigstore-go (Go): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45395/ (Markdown: https://insights.sbomify.com/CVE-2024-45395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45395
- OSV: https://osv.dev/vulnerability/CVE-2024-45395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45395/
Summaries are generated and may contain mistakes; the official description above is the record.
