# CVE-2024-45399: Indico has a Cross-Site-Scripting during account creation

> Attackers can execute arbitrary scripts in the context of newly created Indico users via a malicious redirect link during account signup.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2024
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-rrqf-w74j-24ff, PYSEC-2024-90

## What is CVE-2024-45399?

CVE-2024-45399 is a medium-severity cross-site scripting vulnerability in indico, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In Indico prior to version 3.3.4, corresponding to Flask-Multipass prior to version 0.5.5, there is a Cross-Site-Scripting vulnerability during account creation when redirecting to the `next` URL. Exploitation requires initiating the account creation process with a maliciously crafted link, and then finalizing the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users. Indico 3.3.4 upgrades the dependency on Flask-Multipass to version 0.5.5, which fixes the issue. Those who build the Indico package themselves and cannot upgrade can update the `flask-multipass` dependency to `>=0.5.5` which fixes the vulnerability. Otherwise one could configure one's web server to disallow requests containing a query string with a `next` parameter that starts with `javascript:`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1395 (Dependency on Vulnerable Third-Party Component)

## Which versions are affected by CVE-2024-45399?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | All versions | 3.3.4 |
| `indico` | PyPI | All versions | 3.3.4 |
| `indico` | PyPI | All versions | 3.3.4 |

Products: Cern Indico.

## How do I fix CVE-2024-45399?

Upgrade indico to 3.3.4 or later.

## Is CVE-2024-45399 being exploited?

There is no known exploitation of CVE-2024-45399 in the wild and no public exploit code.

## Other vulnerabilities in indico

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45399 and fix it if it is affected.

What it is: CVE-2024-45399 is a medium-severity cross-site scripting vulnerability in indico, published on 4 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-45399 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected all versions; fixed in 3.3.4
- indico (PyPI): affected all versions; fixed in 3.3.4
- indico (PyPI): affected all versions; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45399/ (Markdown: https://insights.sbomify.com/CVE-2024-45399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45399
- OSV: https://osv.dev/vulnerability/CVE-2024-45399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45399/
Summaries are generated and may contain mistakes; the official description above is the record.
