{"answers":{"affected":"3 open source packages ship an affected version, including github.com/stripe/stripe-cli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-45401 in the wild and no public exploit code.","fix":"Upgrade github.com/stripe/stripe-cli to 1.21.3 or later.","what":"CVE-2024-45401 is a high-severity path traversal vulnerability in stripe-cli, published on 5 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-45401 and fix it if it is affected.\n\nWhat it is: CVE-2024-45401 is a high-severity path traversal vulnerability in stripe-cli, published on 5 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-45401 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/stripe/stripe-cli (Go): affected from 1.11.1; fixed in 1.21.3\n- github.com/stripe/stripe-cli (Go): affected from 1.11.1; fixed in 1.21.3\n- github.com/stripe/stripe-cli (Go): affected from 1.11.1; fixed in 1.21.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45401/ (Markdown: https://insights.sbomify.com/CVE-2024-45401/index.md)","id":"CVE-2024-45401","markdown":"https://insights.sbomify.com/CVE-2024-45401/index.md","name":"CVE-2024-45401","record":{"aliases":["GHSA-fv4g-gwpj-74gr","GO-2024-3119"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Stripe CLI tool","requires_auth":"low_privilege","summary":"A path traversal flaw in Stripe CLI allows arbitrary file overwrites via malicious plugin archives, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"stripe_cli","vendor":"stripe"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"stripe-cli Path Traversal vulnerability","id":"CVE-2024-45401","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Picotls double free","id":"CVE-2024-45402"},"packages":[{"ecosystem":"Go","fixed":["1.21.3"],"introduced":["1.11.1"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":null,"source":"GHSA-fv4g-gwpj-74gr"},{"ecosystem":"Go","fixed":["1.21.3"],"introduced":["1.11.1"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":"pkg:golang/github.com/stripe/stripe-cli","source":"GHSA-fv4g-gwpj-74gr"},{"ecosystem":"Go","fixed":["1.21.3"],"introduced":["1.11.1"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":"pkg:golang/github.com/stripe/stripe-cli","source":"GO-2024-3119"}],"prev":{"headline":"CKEditor Open Link plugin vulnerable to Cross-site Scripting","id":"CVE-2024-45400"},"products":["stripe-cli"],"published":"2024-09-05","related":[{"cvss_score":7.7,"headline":"Code injection in Stripe CLI on windows","id":"CVE-2022-24753","kev_date_added":null,"published":"2022-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-19","vendors":["stripe"]},"summary":"A path traversal flaw in Stripe CLI allows arbitrary file overwrites via malicious plugin archives, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2024-45401/"}