{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45404 exists.","fix":"Upgrade pycti to 6.2.18 or later.","what":"CVE-2024-45404 is a high-severity authentication bypass vulnerability in OpenCTI-Platform opencti, published on 11 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-45404 and fix it if it is affected.\n\nWhat it is: CVE-2024-45404 is a high-severity authentication bypass vulnerability in OpenCTI-Platform opencti, published on 11 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45404 exists.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected all versions; fixed in 6.2.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-45404/ (Markdown: https://insights.sbomify.com/CVE-2024-45404/index.md)","id":"CVE-2024-45404","markdown":"https://insights.sbomify.com/CVE-2024-45404/index.md","name":"CVE-2024-45404","record":{"aliases":["GHSA-hg56-r6hh-56j7","PYSEC-2024-297"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI platform","requires_auth":"low_privilege","summary":"Attackers can brute-force OTPs to bypass two-factor authentication and hijack accounts due to missing rate limiting in OpenCTI.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"gix-path improperly resolves configuration path reported by Git","id":"CVE-2024-45405"},"packages":[{"ecosystem":"PyPI","fixed":["6.2.18"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2024-297"}],"prev":{"headline":"H2O assertion failure when HTTP/3 requests are cancelled","id":"CVE-2024-45403"},"products":["opencti"],"published":"2024-12-11","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-12","vendors":["OpenCTI-Platform"]},"summary":"Attackers can brute-force OTPs to bypass two-factor authentication and hijack accounts due to missing rate limiting in OpenCTI.","url":"https://insights.sbomify.com/CVE-2024-45404/"}