# CVE-2024-45404: OpenCTI's lack of Rate Limit lead to OTP brute forcing

> Attackers can brute-force OTPs to bypass two-factor authentication and hijack accounts due to missing rate limiting in OpenCTI.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2024
- **Updated:** 12 Dec 2024
- **Also known as:** GHSA-hg56-r6hh-56j7, PYSEC-2024-297

## What is CVE-2024-45404?

CVE-2024-45404 is a high-severity authentication bypass vulnerability in OpenCTI-Platform opencti, published on 11 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-45404?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.2.18 |

Products: Citeum Opencti.

## How do I fix CVE-2024-45404?

Upgrade pycti to 6.2.18 or later.

## Is CVE-2024-45404 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45404 exists.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2026-21887](https://insights.sbomify.com/CVE-2026-21887/): OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45404 and fix it if it is affected.

What it is: CVE-2024-45404 is a high-severity authentication bypass vulnerability in OpenCTI-Platform opencti, published on 11 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45404 exists.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.2.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45404/ (Markdown: https://insights.sbomify.com/CVE-2024-45404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45404
- OSV: https://osv.dev/vulnerability/CVE-2024-45404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45404/
Summaries are generated and may contain mistakes; the official description above is the record.
