# CVE-2024-45409: The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

> An unauthenticated attacker can forge SAML responses to log in as any user due to improper signature verification in the Ruby SAML library.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2024
- **Updated:** 11 Nov 2024
- **Also known as:** BIT-gitlab-2024-45409, DEBIAN-CVE-2024-45409, DLA-3949-1, DSA-5774-1, GHSA-jw9c-mfg7-9rx2, UBUNTU-CVE-2024-45409

## What is CVE-2024-45409?

CVE-2024-45409 is a critical authentication bypass vulnerability in Gitlab Gitlab, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-45409?

5 open source packages ship an affected version, including gitlab and ruby-saml. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3 |
| `ruby-saml` | RubyGems | All versions | 1.12.3 |
| `ruby-saml` | RubyGems | All versions | 1.12.3 |
| `ruby-saml` | RubyGems | From 1.13.0 | 1.17.0 |
| `ruby-saml` | RubyGems | From 1.13.0 | 1.17.0 |

Products: Gitlab Gitlab, Omniauth Omniauth Saml, Onelogin Ruby-Saml.

## How do I fix CVE-2024-45409?

Upgrade gitlab to a fixed version for your release line: 16.11.10, 17.0.8, 17.1.8 or 17.2.7.

## Is CVE-2024-45409 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45409 exists.

Public exploit code:

- Ruby-SAML / GitLab Authentication Bypass (CVE-2024-45409) exploit (github_poc): https://github.com/synacktiv/CVE-2024-45409
- https://github.com/barkotenicholas/CVE-2024-45409 (github_poc): https://github.com/barkotenicholas/CVE-2024-45409

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45409 and fix it if it is affected.

What it is: CVE-2024-45409 is a critical authentication bypass vulnerability in Gitlab Gitlab, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-45409 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3
- ruby-saml (RubyGems): affected all versions; fixed in 1.12.3
- ruby-saml (RubyGems): affected all versions; fixed in 1.12.3
- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.17.0
- ruby-saml (RubyGems): affected from 1.13.0; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45409/ (Markdown: https://insights.sbomify.com/CVE-2024-45409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45409
- OSV: https://osv.dev/vulnerability/CVE-2024-45409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45409/
Summaries are generated and may contain mistakes; the official description above is the record.
