# CVE-2024-45436: Ollama can extract members of a ZIP archive outside of the parent directory

> Attackers can extract files outside the intended directory via malicious ZIP archives, potentially reading or modifying sensitive system files.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2024
- **Updated:** 29 Aug 2024
- **Also known as:** CVE-2024-7773, GHSA-846m-99qv-67mg, GO-2024-3104

## What is CVE-2024-45436?

CVE-2024-45436 is a critical path traversal vulnerability in n/a, published on 29 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

extractFromZipFile in model.go in Ollama before 0.1.47 can extract members of a ZIP archive outside of the parent directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-45436?

3 open source packages ship an affected version, including github.com/ollama/ollama. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ollama/ollama` | Go | All versions | 0.1.47 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.47 |
| `github.com/ollama/ollama` | Go | All versions | 0.1.47 |

Products: Ollama Ollama.

## How do I fix CVE-2024-45436?

Upgrade github.com/ollama/ollama to 0.1.47 or later.

## Is CVE-2024-45436 being exploited?

There is no known exploitation of CVE-2024-45436 in the wild and no public exploit code.

Public exploit code:

- exploit script for CVE-2024-45436 (github_poc): https://github.com/srcx404/CVE-2024-45436

## Other vulnerabilities in n/a

- [CVE-2025-63389](https://insights.sbomify.com/CVE-2025-63389/): Ollama Platform has missing authentication enabling attackers to perform model management operations (critical 9.8)
- [CVE-2026-7482](https://insights.sbomify.com/CVE-2026-7482/): Ollama heap out-of-bounds read in GGUF tensor parsing leaks server process memory to unauthenticated remote attackers (high 8.8)
- [CVE-2024-37032](https://insights.sbomify.com/CVE-2024-37032/): Ollama does not validate the format of the digest (sha256 with 64 hex digits) (high 8.8)
- [CVE-2025-15514](https://insights.sbomify.com/CVE-2025-15514/): Ollama Multi-Modal Model Image Processing NULL Pointer Dereference (high 8.7)
- [CVE-2024-39720](https://insights.sbomify.com/CVE-2024-39720/): Ollama Out-of-bounds Read (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-45436 and fix it if it is affected.

What it is: CVE-2024-45436 is a critical path traversal vulnerability in n/a, published on 29 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-45436 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.47
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.47
- github.com/ollama/ollama (Go): affected all versions; fixed in 0.1.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-45436/ (Markdown: https://insights.sbomify.com/CVE-2024-45436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-45436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-45436
- OSV: https://osv.dev/vulnerability/CVE-2024-45436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-45436/
Summaries are generated and may contain mistakes; the official description above is the record.
