CVE-2024-45477 Apache NiFi: Improper Neutralization of Input in Parameter Description

Medium 4.6 Published Updated

Authenticated users can inject JavaScript into parameter descriptions, leading to XSS attacks within the victim's session context.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-45477?

CVE-2024-45477 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 29 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.

Weakness: CWE-79

Which versions are affected by CVE-2024-45477?

5 open source packages ship an affected version, including org.apache.nifi:nifi-web-ui and nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi-web-ui MavenFrom 1.10.01.28.0
org.apache.nifi:nifi-web-ui MavenFrom 1.10.01.28.0
org.apache.nifi:nifi-web-ui MavenFrom 2.0.0-M12.0.0-M4
org.apache.nifi:nifi-web-ui MavenFrom 2.0.0-M12.0.0-M4
nifi BitnamiFrom 1.10.01.28.0

Products include Apache Nifi.

How do I fix CVE-2024-45477?

Upgrade org.apache.nifi:nifi-web-ui to a fixed version for your release line: 1.28.0 or 2.0.0-M4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-45477 being exploited?

There is no known exploitation of CVE-2024-45477 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as BIT-nifi-2024-45477, GHSA-7mqj-xgf8-p59v.

Is CVE-2024-45477 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free